Need Help G4 iBook won't boot off CD

Discussion in 'PowerPC Macs' started by smackshack, Jun 16, 2007.

  1. smackshack macrumors newbie

    Jun 16, 2007
    This is the first time I've had to post in a forum in a LONG time, so forgive me for any mistakes I make.

    I have a iBook G4 1.2 running 10.4.9. About a month ago my computer crashed and I had to hard reboot it. After that my hard drive would not appear on the desktop or in the finder window. Everything works fine but any access to the drive via it's actual icon in the finder is grayed out or non-existent. I had this happen before a month earlier and decided I'd back it up and reformat and reinstall osx. When I tried to reboot from a CD it will spin up but then go to the HD. If I choose it in the startup disk cp it will confirm that I have to restart and then beep and nothing will happen. If i leave it selected and manually reboot it still won't work.

    I have ran Disk utilities both manually and in target disk mode from another computer and it says everything is fine. I went out and got a copy of disk warrior but since I can't boot off a CD it can't do much for me.

    I've cleared the PRAM several time, cleared the NVRAM, openfirmware, and the CUDA. Noting makes a difference; the drive will not show up on the desktop and it won't boot off of any CD. I am out of ideas and can't find anyone else with this sort of problem. Like I said this happened before with the HD not mounting on the desktop but I was able to reinstall that time.

    Any ideas?

    Thanks in advance!
  2. rrijkers macrumors 6502


    Jun 6, 2007
    The Netherlands
    Maybe you can try booting from another CD/dvd as the one you use now (holding down C-key while booting). Maybe a 10.3 disc or even a OS9 disc?

    Good luck :rolleyes:
  3. smackshack thread starter macrumors newbie

    Jun 16, 2007

    Thanks, I did try that. I've tried the flowing disk both using the control panel startup disk option and holding down the "c" key. Same problem every time.

    OS X 10.4.9
    OS X 10.3.x
    OS 9.2.2
  4. ahernd macrumors newbie

    Jun 18, 2007
    Any luck with this?

    Did you have any luck with this?

    I have similar problem, I installed a new 120gb hard drive and tried booting up using the 'c' button but it just displays the happy face and question mark, also tried booting up with the 'option' button but this doesn't even show an OS which I'm quite sure is because nothing is installed yet. So looks like the only option I have as far as I know is to boot from the 'Mac Install Disk'.

  5. luke-armstrong macrumors newbie

    Jul 15, 2007
    I can't reinstall OS either...

    Phew, so I'm not the only one having problems with my supposedly-user-friendly indomitable Mac!

    I have just bought a 'used' iBook G4 which was said to have had a faulty HDD. I took-out the old 40GB, replaced it with an 80GB and tried to re-install the OS from the original installation discs by holding down c when starting-up. I have tried dozens of times and it usually give me the Apple screen, makes a lot of whirring noises then gives me a dead blue screen (crash?). Occasionally, however, it has let me start the installation but, each time, it just gets as far as the destination disk screen only to show me a red exclamation sign over the disk icon with a notice saying that the OS cannot be installed onto this disk (no explanation why!). I have tried erasing and repairing the new disc, but it makes no difference.
    I've lost hours on this (the new disk took forever to install!) and I am losing the patience to face disassembling the whole machine again...

    I need help please!!! (otherwise the iBook goes through the window and I buy an IBM PC! (yes, it really is that frustrating!)

Share This Page