Need Help - iMac Wont Boot After Recent SL Graphics Update

Discussion in 'macOS' started by Evo-L, Aug 18, 2010.

  1. Evo-L macrumors member

    Joined:
    Feb 28, 2008
    #1
    So Im having my first ever problem with a Mac, bummer! I have tried Googling an answer, but didn't find anything specific enough for my situation.


    Last night I installed the SL Graphics Update, hoping to be able to run Starcraft 2 on a higher setting.

    Anyways, I installed it, and now the computer wont boot. It is stuck on the gray screen with the spinning symbol. It appears to be installing the software update, since it shows a gray progress bar, but then once that finishes, it just stays on the gray screen with the spinning symbol and goes nowhere after that.

    I have a Macbook Pro available to use, if I need to target the disk. Not sure how to do that though, just found that idea in my google search.

    I have no problem just being able to grab my important data off of it, and starting on a fresh install. I just dont want to lose my huge library of pictures and music.

    Thanks All!
     
  2. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #2
    Have you tried a forced shutdown - hold in power switch until it powers off, then pull the power plug for a minute, plug it back in and try to boot?
     
  3. Evo-L thread starter macrumors member

    Joined:
    Feb 28, 2008
    #3
    I have done that exact procedure except I did not pull the power cord, would that make a difference?

    Thanks for the suggestion, I will try it in a few when Im home.

    If anyone has anything else, please let me know.
     
  4. Evo-L thread starter macrumors member

    Joined:
    Feb 28, 2008
    #4
    I tried unplugging it and simply restarting and it didn't work.

    I reset the PRAM and it booted once, but with practically no functionality. So I restarted it thinking a restart would work. Unfortunately I'm now back at square one.

    Any ideas anyone?
     
  5. dougeb macrumors newbie

    Joined:
    Mar 7, 2010
    Location:
    Pleasant Hill, CA
    #5
    It took my 2010 Macbook Pro 15 minutes of spinning wheel before reboot.
    You may have to wait an half hour.
     
  6. Evo-L thread starter macrumors member

    Joined:
    Feb 28, 2008
    #6
    I actually let it go overnight after the first time. I let it run about 30 mins the first time, then restarted it and let it run the whole night. I thought maybe it messed up and a reboot would solve it.

    Either way, I have let it sit for much longer than 30 minutes.

    Thanks for the suggestion though.
     
  7. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #7
    Run FSCK - see sticky Guide at top of this forum. If you want to learn more about its options, see here
     
  8. Evo-L thread starter macrumors member

    Joined:
    Feb 28, 2008
    #8
    Ok, I just did that.

    This is what it says:

    ** Checking catalog file
    Invalid index key
    (4, 46344)
    ** Rebuilding catalog B-tree
    ** The volume Macintosh HD could not be repaired.

    ** FILE SYSTEM WAS MODIFIED **

    ---------------------------------------------


    After that, I type reboot, and unfortunately I get the same problem.

    Ok, so Im starting to realize that I may need to reformat this thing. Is there any way to get my data off of my HD? Can I Firewire Target and get the data off?
     
  9. Damo01 macrumors regular

    Joined:
    Feb 11, 2010
    Location:
    Australia
    #9
    Have you tried repairing the disk from your SL Installation Media Disc?

    Another alternately way. Turn off your Computer and reboot it. Before you hear the startup tone or chime hold down the alt key on the keyboard. This bright up the boot selection on the screen. Insert your snow leopard Installation Media Disc. Go to Utilities and open up Disk Utility and try repairing from there.
     
  10. MaskingTape macrumors regular

    Joined:
    Jan 9, 2009
    #10
    try 2 more things - starting in safe mode and turning on verbose mode

    to try to boot in safe mode hold down the shift key when booting. this will bypass any 3rd party kexts, programs, etc.

    If that works restart in verbose mode. Hold down command+v while booting. This will show whats trying to load and where it hangs. Maybe that information will be useful to someone a bit more knowledgeable than I.
     
  11. Evo-L thread starter macrumors member

    Joined:
    Feb 28, 2008
    #11
    Ok, well I booted from the disk, and it loaded it up. Great news!

    But, then I ran Disk Utility and it was unable to repair the disk. It just says "Disk Utility is unable to repair this disk, and you should save any files you can from it and reinstall OSX".

    So, at this point, how exactly do I recover files from it and reinstall OSX?

    I just dont want to lose my business files and my pictures.

    Thanks for the help so far.
     
  12. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #12
    Where is your backup?

    Boot in Single-User-Mode and run fsck -fy. It it reports back it modified something, run the same command again and again until it doesn't report any modifications. If if can't get a new hard drive and a Firewire enclosure . Do a fresh Snow Leopard install and update it to the latest updates. Then put you old drive in the Firewire enclosure. Finally go to /Applications/Utilities/Migration Assistant and import your data from your old drive.

    Finally get another hard drive to put in that Firewire enclosure and use it for a backup!!!
     
  13. Evo-L thread starter macrumors member

    Joined:
    Feb 28, 2008
    #13
    Well nothing worked, so I had to resort to your last suggestion. I got a new 1TB HDD, installed a fresh SL on it, then put the old drive in an enclosure.

    I had to Disk Warrior the old drive to get it to work, but that program allowed me to recover all of my data. I am now using my old drive for backups. :)

    Thanks guys.
     
  14. Evo-L thread starter macrumors member

    Joined:
    Feb 28, 2008
    #14
    Now I just have to cure this HDD fan dilemma...
     
  15. NXTMIKE macrumors 6502

    Joined:
    Nov 11, 2008
    Location:
    Canada
    #15
    What is the status of your iMac's AppleCare warranty?
    ....whether it's the 1 year or 3 year extended.
     

Share This Page