Need help in Single User Mode - Avast crashed my computer

Discussion in 'Mac Basics and Help' started by Cynelle, Feb 28, 2013.

  1. Cynelle macrumors newbie

    Joined:
    Feb 28, 2013
    #1
    Running Leopard on my Macbook. I got a notification yesterday that Avast had an update available. So I updated and it asked to reboot. It got stuck rebooting and now will not load. It gets stuck on the grey screen with the apple and the spinning circle. It will not load in safe mode - just get the bar then the forever spiining circle. My optical drive is shot so I can't run the disk repair from that.

    I've ran in verbose mode and the last item it shows before getting hung up is com.avast.AvastFileShield: Started

    So I'm guessing that I need to delete/ remove Avast from my system. I can load in single user mode but I'm more familiar with DOS and Windows then Unix and it's command line interface so I need help. I need help navigating to the directory where the program is and deleting it.
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #2
    Boot into Safe mode instead of single-user mode.
    http://support.apple.com/kb/ht1564

    In Safe mode, use Spotlight to find the failing extension (or whatever) and delete it.
     
  3. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #3
    The OP said he wasn't able to Safe Boot.
     
  4. Cynelle thread starter macrumors newbie

    Joined:
    Feb 28, 2013
    #4
    Yea I wish I could get it to go into safe mode. All it does is start loading the progress bar and then it goes blank and goes back to the grey apple screen and the spinning circle of death.
    I posted on the Avast site as well and apparently I'm not the only one but it's still not working yet.

    What could be the reasons that it won't go into safe mode? or the repair (command + R)?
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    Recovery System is only available in 10.7 (Lion) or later. You can get into something similar by booting from your Leopard DVD.
     
  6. Cynelle thread starter macrumors newbie

    Joined:
    Feb 28, 2013
    #6
    Bummer - Do you think the following would work? Getting an external DVD drive and plugging it into the laptop to try and boot from that? Given that it's never had a drive hooked up to it, I don't know whether it would recognize it.
     
  7. Cynelle thread starter macrumors newbie

    Joined:
    Feb 28, 2013
    #7
    How do I get Library loaded??

    well I followed the advice from Avast which was:
    /sbin/mount -uw /
    "/Library/Application Support/Avast/install.sh" uninstall
    reboot

    However I got an error after the uninstall command relating to 2 separate kext unable to find 2 of the files to uninstall them - one of them being the AvastFile Shield.

    It's still not loading. Now when I try to do some of the other commands I keep getting this message or versions of it:
    dyld: Library not loaded: System/Library/PrivateFrameworks/Mediakit.framework/Versions/A/MediaKit
    Referenced from: System/Library/PrivateFrameworks/DiskManagement.framework/Versions/A/DiskManagement
    Reason: image not found
     

Share This Page