Need Help in Updating to 2.1 or Higher

Discussion in 'Jailbreaks and iOS Hacks' started by wilmer007, Feb 18, 2009.

  1. wilmer007 macrumors member

    Joined:
    Oct 12, 2008
    #1
    Ok heres my story. I bought my iPhone 2G (EDGE) from a guy on craigslist, he gave it to me with 2.1 unlocked i've had it for about 6 months now, no problems. A few days ago i wanted to update to 2.2.1 to see if i would get a longer battery life as i noticed my battery was draining quickly. Me being a dummy and not going online i updated through iTunes and upgraded my baseband, i spent over 8 hours that night trying to get quickpwn to detect my iphone but nothing it kep telling me to plug my iphone into the usb and it was plugged in. iTunes detects my iphone just fine though. Anyways after trying and trying i was able to get my phone up and running after using WinPwn and going down to 2.0.1 i'm guessing i also was able to lower my baseband aswell when i downgraded from 2.2.1, now when i tried to get my backup with my contacts and stuff from itunes it won't because i'm using an older version from the backup i made which was 2.1. Now how can i get quickpwn to detect my iphone so that i can update back to at least 2.1? Or is there another way to get my problem fixed. I need my contacts restored more than anything and would like to go back to at least 2.1.

    I do not have another pc to try updating with and i can only rely on my laptop. I believe my USB 2.0 drivers are acting up and i've tried to find the driver's online but nothing and i can not afford to restore my pc from "out of the factory state".


    So i really need some help with this as i need all my contacts back ASAP.
     
  2. Four20 macrumors 6502a

    Four20

    Joined:
    Sep 22, 2007
    #2
    i don't think you don't have to use quickpwn to get back to 2.1

    if you download the 2.1 firmware and hold SHIFT then click RESTORE in itunes it will ask you for the firmware you want to use
     
  3. wilmer007 thread starter macrumors member

    Joined:
    Oct 12, 2008
    #3
    I have tried that many times all i get are errors such as 1611 and 1403. I've tried going to 2.1, 2.2., 2.2.1 and i just get unknown error 1403 or error 1611 which i have no clue how to fix that error. I've even tried custom FW i found that skips having to use quickpwn as they were made with pwnagetool and all i get is unknown error 1403.
     
  4. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #4
    I remember gettings loads of errors whilst trying to do a shift-click restore. Try put the phone into DFU mode, and then do a shift-click restore.
     
  5. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #5
    I agree, go into DFU mode to reload the firmware.

    It's a 2G phone, so the baseband for 2.2.1 is not a problem, that's a 3G phone issue, so you're fine to go to 2.2.1 standard firmware file.

    If it's a macbook on 10.5.6.then you'll need to plug a powered USB hub into it, as there's a current software glitch with that version. The hub fixes it.
     
  6. wilmer007 thread starter macrumors member

    Joined:
    Oct 12, 2008
    #6
    I got my phone unlocked and updated to 2.2.1. Turns out my drivers or pc is screwed up. I downloaded quickpwn on a buddies pc to see if it responded and i was able to get the blue arrow so i knew i was good to go. So i downloaded the 2.2.1 firmware to his pc and used quickpwn without a hitch and now i have 2.2.1 unlocked and jailbroken and lovin it. Thanks for the help anywayz guys, guess i'll have to either do a "factory state" on my pc or figure out how to fix my usb drivers.

    And for the record all those errors i got, i got them in either restore or dfu, so i tried everything possible till i tried another pc.
     

Share This Page