Need Help Intalling Couch Surfer 0.6 on Apple TV

Discussion in 'Apple TV and Home Theater' started by MacFlash, Jan 28, 2009.

  1. MacFlash macrumors newbie

    Joined:
    Sep 29, 2008
    #1
    Hey guys, I have seen some excellent help threads for installing Couch Surfer on the Apple TV on this forum, but I have run up against a problem that I cannot solve, and that I cannot find an existing resource to help here or anywhere else. Any help would be appreciated.

    The problem:

    When I try to move the CouchSurfer.frappliance file from the users/frontrow directory it gives me a "permission denied" prompt.

    The background:
    Apple TV 2.3
    Couch Surfer 0.6
    SSH installed with the ATV USB Loader along with Boxee (which works great)
    I used the install directions from this site: Couch Surfer 0.6 awkward TV wiki

    So I CyberDucked into the AppleTV, and copied the whole Couch Surfer folder into users/front row. At that point I logged out of the CyberDuck session and opened the ATV SSH session in my terminal. I then went into the users/front row directory and, then I unzipped the folder, which went fine. Then I tried to move the plugin to the finder.app plugin folder with the terminal command:

    mv CouchSurfer.frappliance /System/Library/CoreServices/Finder.app/Contents/PlugIns/

    at that point I get the prompt that is something like:

    rename users/frontrow/CouchSurfer.frappliance to /System/Library/CoreServices/Finder.app/Contents/PlugIns/CouchSurfer.frappliance failed: permission denied

    I have tried a few things including going back in with CyberDuck and removing the files and starting from scratch. I also unzipped the folder on my desktop and tried putting the couchsurfer.frappliance directly into the users/frontrow folder and then moving it with SSH, but all with no luck.

    If anyone has any ideas or has gotten past this problem, then please let me know. It looks like this install method is a moving target with each version of Couch Surfer and ATV requiring a little different "secret sauce." So hopefully, its my lack of SSH experience that is causing the issue, and it will be a simple fix. Or am I missing something on the versions and will I be unable to run Couch Surfer on the ATV 2.3 firmware?

    Thanks in advance for any help.
     
  2. MacFlash thread starter macrumors newbie

    Joined:
    Sep 29, 2008
    #2
    Update

    Well I never got any help or responses on this forum, but I got it figured out myself through trial and error. I could not believe this thread was the top hit on Google when I searched for this possible issue, so I figured it may help the next guy if I updated this thread. I'm surprised with some of the lack of background or instructions on these Apple TV hacks. I guess there really are not that many people out there doing this stuff.

    Anyway, it appears that the AppleTV requires certain privileges to move the couchsurfer.frappliance to the plugins folder in the system/library directory.

    So what I had to do was add a sudo command in front of the move command I had been using.

    So now after cd'ing into the users/front row folder where I unzipped couch surfer what I was typing into the terminal as:

    mv CouchSurfer.frappliance /System/Library/CoreServices/Finder.app/Contents/PlugIns/

    I now typed in as:

    sudo mv CouchSurfer.frappliance /System/Library/CoreServices/Finder.app/Contents/PlugIns/

    It then asked for the password, which is frontrow, and boom, it was done.

    Some of the earlier CouchSurfer instructions included a sodu command for other steps,which is where I got it from. So I took a gamble and tried it, and it worked. But, I am not a SSH expert by any stretch and I think you can mess stuff up by using the sodu command in inappropriate manners so be careful on this one.

    It got couch surfer working, and its really a great add on for the Apple TV. Now I just need to get flash working.
     
  3. jayrobinson macrumors newbie

    jayrobinson

    Joined:
    Sep 8, 2008
    Location:
    Palo Alto, CA
    #3
    When I tried this, I get this error message:

    Code:
    mv: rename CouchSurfer.frappliance to /System/Library/CoreServices/Finder.app/Contents/PlugIns/CouchSurfer.frappliance: Read-only file system
     
  4. killbot macrumors newbie

    Joined:
    Jul 13, 2007
    #4
    Just logged in to say - thanks!
     
  5. killbot macrumors newbie

    Joined:
    Jul 13, 2007

Share This Page