Need help keeping NAS mounted after MacBook sleeps

Discussion in 'Mac OS X Server, Xserve, and Networking' started by bluelightalarm, Oct 1, 2015.

  1. bluelightalarm macrumors newbie

    Joined:
    Aug 26, 2011
    Location:
    South Wales, UK
    #1
    Hi I wonder if someone here would be willing to help please?

    I got a MacBook Pro a few weeks ago, this is my first time ever using a Mac, I've always had Windows machines in the past. I'm loving it mostly but there are a few things that I just can't figure out, mainly how to keep my NAS mounted - it just doesn't want to stay for some reason!

    I have Plex installed on my MacBook and the video files saved on a WD MyCloud drive. I managed to add the mount to my startup items so it auto mounts every time I restart but for some reason, several times a day it loses the connection and I have to manually connect again before I can watch anything using Plex and it's getting really annoying now.

    I've googled for a solution and have found loads of pages mentioning to write a script to check if the drive is mounted and if not then mount it, but no matter how many times I try to do this I just can't get it to work for me - it's just all a bit too much for me to understand as I have literally zero experience or knowledge of this kind of thing!

    Could someone please help me out?

    Thanks
    Jamie
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Depends. It sounds as if the drives go to sleep and don't get the wake command from the woke up Mac! How is it connected, FireWire, Thunderbolt, USB 3?
     
  3. DJLC macrumors 6502a

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #3
    I typically have the opposite problem; file shares stay connected even after I've left the network where they exist! And the Finder loses its mind when I try to eject them.

    My best advice would be to add the shared volume to the dock. That way if it's disconnected, it just takes a single click to reconnect. (Drag the disk to the right side of the line in the dock; next to the Trash / Eject icon.)
     
  4. bluelightalarm thread starter macrumors newbie

    Joined:
    Aug 26, 2011
    Location:
    South Wales, UK
    #4
    It's connected wirelessly. I changed the settings on the drive to disable sleep so I don't think it's a problem with the drive, I think it's something that OS X is doing

    If I'm using the computer then it's just a case of pressing command + K to re-connect to the drive - it's when I'm not actually at the computer but want to watch something on Plex when I'm getting the problem.

    Thanks anyway for your replies though
     
  5. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #5
    What makes you so sure about that? Has it been doing that since you had a Mac?
     
  6. bluelightalarm thread starter macrumors newbie

    Joined:
    Aug 26, 2011
    Location:
    South Wales, UK
    #6
    It's only been doing it since I got the MacBook. If I connect with my old Windows laptop then it works fine and keeps the connection permanently but when I try with my MacBook it loses the connection several times a day
     
  7. flashmac76 macrumors newbie

    flashmac76

    Joined:
    Aug 8, 2012
    #7
    hi bluelightalarm
    I've come across exactly this issue too and adopted a simple application for which I shelled out a little bit of money. But it's fully worth it. I've fiddled with scripts and startup items, but in the end it was too much of a fiddle and unreliable.

    The app is called drive mounter: https://itunes.apple.com/app/drive-mounter/id441149468?ls=1&mt=12
    You'll have to shell out a bit under $7. But at least now I have one worry less.

    enjoy
     
  8. bluelightalarm thread starter macrumors newbie

    Joined:
    Aug 26, 2011
    Location:
    South Wales, UK
    #8
    THANK YOU!!!!! I downloaded it last night and have had no trouble at all today - worth every penny!
     

Share This Page