Need Help....New Project Xcode internal error

Discussion in 'Mac Programming' started by NSG10, Aug 26, 2010.

  1. NSG10 macrumors member

    Joined:
    Aug 26, 2010
    #1
    Hey guys, every time I try to create a new project in Xcode i get this error

    File: /SourceCache/DevToolsBase/DevToolsBase-1608/pbxcore/SourceControlManagement/SCMG3/SCMModel.m
    Line: 87
    Object: <SCMModel>
    Method: initialize

    couldn't create ~/.Xcode

    What does it exactly mean and how is the fix for it?:mad:
     
  2. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #2
    You could try creating the folder manually in Terminal. Type this in Terminal:
    Code:
    mkdir ~/.xcode
    But if Xcode can't make that folder something must be messed up with your permissions on your home directory, which isn't good. You could try a Repair Permissions from Disk Utility.
     
  3. NSG10 thread starter macrumors member

    Joined:
    Aug 26, 2010
    #3
    I tried terminal and permissions repair and still getting an error.
    Any other solutions thanks.
     
  4. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #4
    Maybe try creating a new (temporary) admin user account and see if you get the same error when logged into that. That might tell you if it's a user permissions problem or something wrong with the Xcode installation/configuration. Are you set as an admin for your machine? Did it used to work and stopped, or it never worked?
     
  5. NSG10 thread starter macrumors member

    Joined:
    Aug 26, 2010
    #5
    Nope still getting the same error....but thanks.
     

Share This Page