Need help ... No DFU

Discussion in 'Jailbreaks and iOS Hacks' started by cez1, Jul 20, 2008.

  1. cez1 macrumors member

    Joined:
    Jul 19, 2008
    #1
    Hi all,

    I will try to make this short as i have posted snippets in other threads.

    A family member gave me his 1st-gen 8GB iphone after he purchased his 3G about 2 weeks ago. It was unlocked and jailbroken and running on the FIDO network in Canada. I played with it for about 3 days and then brought it home hooked it up to my mac and was asked to upgrade iTune to 7.7, which i did and then stupidly upgraded to 2.0 firmware and of course it was locked. I tried several time to downgrade but could not, and figured i would just wait for pwnage 2.0.

    Downloaded pwnage 2.0 last night and went through all the steps (~ 15 times) with all the fixes along the way and nothing. I have come to the conclusion that the problem is that i cannot get into DFU mode. Not because i don't have the timing right (believe me i tried and tried and tried), but because there might be a problem with my sleep/wake button. I did not have the unit long so i could be wrong here, but pressing this button should turn the iphone off and it does not when i am in emergency call mode. It is at the DFU step, where i consistently get hung trying to either use pwnage 1.0/2.0 or downgrade.

    I did try a downgrading on a PC (via bootcamp/windows) and even found a windows command line DFU program, which did not put my iphone in DFU mode. But oddly, when i tried to put the phone into DFU manually after running that script i did get a brief flash of the iphone menu screen, complete with icons and all, and then it disappeared.

    Again, sorry for the long post. If anyone has any other suggestions i'd love to try them or else this thing will sit in a drawer or hit craigslist as is (i'm pretty fed up, but hey it was for free anyway).

    Thanks in advance,
    cez
     
  2. cazlar macrumors 6502

    Joined:
    Oct 2, 2003
    Location:
    Sydney, Australia
    #2
    I can't help you if your button really is bad, but the best way to get to DFU in my experience is hold power/home while you count out 10 sec, remove power and hold home for 10 sec more. That usually kicks it into DFU.

    One tip I've mentioned in other threads, but I recommend you try, is to find an old app called USB monitor (freeware but PPC) or Peripheral Vision (shareware but Plasq has an newer intel version buried in a forum post somewhere). Either of these let you see what you are plugging in your USB port. Specifically here, you can see immediately if your iPhone switches to DFU or not, rather than trying to guess which mode it really is in.
     
  3. tedrjr03 macrumors regular

    tedrjr03

    Joined:
    Feb 9, 2006
    #3
    I had the same problem, quick fix:

    Create a new folder:"Device Support" in

    User-Library-itunes
     
  4. cez1 thread starter macrumors member

    Joined:
    Jul 19, 2008
    #4
    I've tried the standard DFU methods and still not good. I will look for the Peripheral Vision for Intel.
    Thanks
     
  5. cez1 thread starter macrumors member

    Joined:
    Jul 19, 2008
    #5
    Thanks tedrjr03,

    I've tried that too, no help.

    Does anyone now of a command line way on a mac to get into DFU mode?
     
  6. cez1 thread starter macrumors member

    Joined:
    Jul 19, 2008

Share This Page