Need help. Not charging

Discussion in 'MacBook Pro' started by giladal, Nov 2, 2011.

  1. giladal macrumors newbie

    Joined:
    Nov 2, 2011
    #1
    My mid 2010 Macbook pro 13" decided to stop charging. I had 5 minutes of battery left, so I connect the magsafe charger, and it showed a steady green led on the charger, and "not charing" on the mac. 5 Minutes later, the computer shutdown and has been dead since. If I push the battery status indicator on the left side, i get one flashing green light on the indicator. I cant turn the laptop on using the power button either connected to the power or not connected. I tried Shift-Option-Control and power and still no change. Applecare customer phone support refused to trouble shoot the proboblem for me, as I am currently not in the USA which was rediculous. I am a pilot and travel alot, and at the moment not in the US.

    Anyways,
    I am thinking its somehow the charger, and hoping it is the charger.

    Anyone ever experience this?
    Any input would be greatly appreciated.


    Thanks.
    Gilad:confused:
     
  2. Summersify macrumors member

    Joined:
    Oct 29, 2011
    Location:
    UK
    #2
    When you connect the charger, is there any light, and if so what colour?

    I'm inclined to say it may be the charger. Whenever you can though, I would go check at an Apple Store

    Jack
     
  3. giladal thread starter macrumors newbie

    Joined:
    Nov 2, 2011
    #3
    Thanks for the reply.

    Well, once i connect tge charger, onvthe charger there is acsolid green light.

    I am really hoping it is the charger as it is just to replace it.

    Your thoughts?

    Gilad
     
  4. GuitarG20 macrumors 65816

    GuitarG20

    Joined:
    Jun 3, 2011
    #4
    It sounds like either a charger issue, a SMC issue, or a battery issue.

    And I am surprised you can't get support, since support should be worldwide.
     
  5. giladal thread starter macrumors newbie

    Joined:
    Nov 2, 2011
    #5
    I went this morning to the apple premium seller here in Israel named IDIGITAL, and they plugged in a different charger and it worked perfectly. I was pretty sure it was the battery or the board as most customers with the same symptoms later found out it was either the battery or the board. Anyways, once again here is what I encountered and what it turned out to be.

    1) Charger connected to computer. Cant operate computer.
    2) Charger not connected to computer, cant operate computer.
    3) Charger connected to computer. Solid green light on the charger.
    4) Battery indicator test on the left side of the computer shows 1 flashing green led. (Indicating low battery power at the time).

    Conclusion:
    The charger (Box to computer) not electrical outlet to the box, was bad.



    Since it will take them here 14 days, to get a new charger from apple, I will be in the UK next week, and will do it there. Better than giving them the laptop for 14 days for no reason.

    Now I am a happy camper. :cool::apple:

    Thanks for the reply! :)
     
  6. GuitarG20 macrumors 65816

    GuitarG20

    Joined:
    Jun 3, 2011
    #6
    14 days to get a new charger? they don't just have them hanging around? 0.o
     
  7. giladal thread starter macrumors newbie

    Joined:
    Nov 2, 2011
    #7
    Nope.


    But now, that I am back from the UK, and the charger seemed to be working fine. It now again isn't working. Its only charging when the wire is facing me... This really six, as I am not going to be in the UK at least until march......

    :mad: GRRRRRRRRR :confused:
     
  8. GuitarG20 macrumors 65816

    GuitarG20

    Joined:
    Jun 3, 2011
    #8
    that would annoy me-i plug in ethernet...

    there's no way to get a new one where you are???
     

Share This Page