Resolved Need help on combining "Free Space" and Boot Drive together:(

Discussion in 'iMac' started by kelf, Dec 14, 2013.

  1. kelf, Dec 14, 2013
    Last edited: Jan 1, 2014

    kelf macrumors newbie

    Joined:
    Oct 25, 2009
    #1
    I was trying to partition my macintosh HD for bootcamp but for some odd reason it failed so i panicked and deleted the partitions on disk utilities now I'm stuck with Mac OS boot partition and a grey un formatable free space with a saying next to it saying

    "The full size of the Fusion Drive is not available for repartitioning"

    Am scared and trying to boot with Mavericks USB to erase my drive and restore from time machine....

    Please help me if you guys know any there options

    PS i tried using ipartition but still no luck....:(:(:(:(:(:(:(


    [Resolved]
    See my reply for solution!
     
  2. hfg, Dec 15, 2013
    Last edited: Dec 15, 2013

    hfg macrumors 68040

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #2
    I think you probably should have used the BootCamp Assistant to create and remove the Windows partition and regain the space for OS X on your Fusion drive. I don't know if that will now be successful after using other utilities, but see what it tells you.
     
  3. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #3
    Perhaps this page might help you resolve the issue.

    You may have inadvertently created, and now need to delete, a new Core Storage Logical Volume group.
     
  4. kelf thread starter macrumors newbie

    Joined:
    Oct 25, 2009
    #4
    Solved!

    BTW guys, sorry for the late update

    problem solved perfectly after i booted to windows installation (without installing windows) and using the installation to delete everything, like literally everything, the SSD and the HD making the two separated. then boot again with my OS X Mavericks USB the installation automatically restore core storage for me (AKA restore the two deleted drives to fusion drive) reinstall mavericks, restore from time machine, all good!

    gave me all the panics for nothing!!

    feel free to PM me if you are fortunate enough to run into a problem like mine

    credits to @Stageshoot
     

Share This Page