Resolved Need Help Please - Unable to install Mountain Lion!

Discussion in 'OS X Mountain Lion (10.8)' started by jedolley, Aug 10, 2013.

  1. jedolley, Aug 10, 2013
    Last edited: Aug 10, 2013

    jedolley macrumors 68000

    Sep 18, 2009
    I manage to screw up my iMac pretty good, and this time I can't seem to resolve this on my own...

    The story on how I got here is pretty long, so I will just give you the current issue. I was attempting a fresh install of Mountain Lion using a Bootable USB. I started the install and got to the part where I would selected my hard drive, but it was grayed out and when I clicked on it I got the error "This Disk Cannot Be Used To Startup".

    I read up on the error and the recommendation was to create a separate partition, so I exited out of the install and opened up the Disk Utility, but the Partition options are all grayed out. I read up on that issue, and saw recommendations to partition it via the Terminal. I tried the recommendations, but it did not work. I did a "diskutil list" and below are my results. It seems, for whatever reason, my Mac HD partition is the only one that is not a "GUID_partition_scheme". I'm not sure how I go about fixing this since everything is grayed out, and i'm not an expert with Terminal.

    Jasons-iMac:~ jedolley$ diskutil list
    0: GUID_partition_scheme *121.3 GB disk0
    1: EFI 209.7 MB disk0s1
    2: Apple_CoreStorage 121.0 GB disk0s2
    3: Apple_Boot Boot OS X 134.2 MB disk0s3
    0: GUID_partition_scheme *1.0 TB disk1
    1: EFI 209.7 MB disk1s1
    2: Apple_CoreStorage 849.3 GB disk1s2
    3: Apple_HFS Recovery HD 650.0 MB disk1s3
    0: Apple_HFS Macintosh HD *961.8 GB disk2
  2. jedolley thread starter macrumors 68000

    Sep 18, 2009
    I was able to resolve this myself...

    In the end I needed to find a way around Disk Utility's in ability to modify the HD or partition. I was working under the theory, that due to the Fusion drive, I had to erase or format the logical volume group. The regular diskutil commands (eraseDisk, eraseVolume, reformat, etc.) had no effect. It was not until I accessed the coreStorage menu that I found options for the logical volume. The command "diskutil coreStorage erase [logical volume ID - which i got from the info]" worked. I then went back into Disk Utility and saw that both the SSD and HDD were in red and once I clicked on them I was given an option to "Fix" them which made them a logical volume again (Fusion). I then started the installation and finally my HDD was selectable and I was able to install.

Share This Page