need help, plz. Problem about jailbreak iphone 4 ios 4.1

Discussion in 'Jailbreaks and iOS Hacks' started by colinwsun, Dec 4, 2010.

  1. colinwsun macrumors newbie

    Joined:
    Feb 2, 2008
    #1
    Hi, there, I just got a wired trouble when I am try to jailbreak my iphone4.


    iphone 4, ios 4.1, 16 gb, BB is 02.10.04.

    instal "pwnage tool for mac", then start to build the firmware, put to into DFU model, it stat to restore. Suddenly, the wired thing happened. "the iphone can not be restore, this device isn't eligible for requested build". I tried a couple time, the problem is same everytime. I googled for 2 hours, the only thing I got is to try it on another computer.

    anyone plz!
     
  2. colinwsun thread starter macrumors newbie

    Joined:
    Feb 2, 2008
    #2
    btw, I can not even just restore with 4.1 firmware, it shows up the same problem!
     
  3. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    This happens because Apple isn't signing the SHSH blobs (Google them) for 4.1 anymore. And unless you have them saved with TinyUmbrella or through Cydia there is no way to get them.
     
  4. dgstan macrumors 6502a

    Joined:
    Jun 29, 2010
    #4
    If you're already on 4.1, why not just use Green Pois0n of Limera1n to do the JB? No need for custom ipsw or Pwnage tool.
     
  5. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #5
    Exactly. GreenPois0n or LimeRa1n will do the trick. PwnageTool is needed if you want to jump to another firmware and save your baseband.
     
  6. thaghost macrumors 6502

    Joined:
    Jun 24, 2010
    Location:
    Romeoville, IL
    #6
    I've been having the same problem. Tried it 4 times and nothing.
     
  7. colinwsun thread starter macrumors newbie

    Joined:
    Feb 2, 2008
    #7
    thanks guys, I tried green poison on a windows laptop, it worked great. Problem solved. cool. so happy about it.
     

Share This Page