Need help quick please!!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by james079, Apr 25, 2011.

  1. james079 macrumors newbie

    Joined:
    Apr 25, 2011
    Location:
    Canada
    #1
    Hi everyone,

    So heres my problem, i have an iPhone 3GS 16GB iOS 4.2.1. It has been jailbroken with Redsn0w since december. It is a tethered jailbreak. Lately ive realized that its too much of a hassle having it tethered so ive wanted to untether it. so ive been looking into restoring it then updating it then getting the 4.3.2 untethered redsn0w jailbreak. The problem is that i tried to restore my iphone to factory settings but it wouldnt let me since itunes said that it had to update first. I realized i couldnt update it since its jailbroken so i decided to try to just reset everything from my phone instead of through itunes. I did that and used redsn0w to boot tethered, and thats where everything went haywire. My phone is now frozen with the restart apple symbol and nothing i do to reset it works. Ive tried booting tethered through redsn0w, ive tried going through recovery mode (the only reason recovery mode didnt work is because it said itunes needed to update the iphone which wont work since my iphone is still jailbroken), ive tried everything i know of. I really need help and answers fast!
     
  2. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
  3. supermac96 macrumors 6502a

    supermac96

    Joined:
    Nov 3, 2010
    Location:
    somewhere over the rainbow
    #3
    let itunes update your phone. it will make you update if you click restore no matter what you try to do (unless you load custom firmware on). you will lose your jailbreak just like you wanted, it will update you to the newest os just like you wanted and you can re-jb just like you wanted. there is really no other possible way to go about this. you say it wont update because your jb but i think it will. just try it, your phone already isnt working so i dont think anything worse can happen.
     
  4. james079 thread starter macrumors newbie

    Joined:
    Apr 25, 2011
    Location:
    Canada
    #4
    Hey guys,

    Thanks for the ideas, but sadly my problem is still not fixed. I have tried dfu mode and it does nothing. I also have tried to update my phone now as ive realized i dont have any other options, but now that wont work for me either. I connect my phone to my computer and a message pops up in itunes saying it found a phone in recovery mode and needs to restore. so i click okay and select restore. At this point i then agree to update and restore my phone etc. and the download for the new update begins. So i wait until its complete but theres a problem. when the download is finished, it doesnt automatically update my phone it just says processing download then it disappears. I have tried this 3 times now and it just wont work!!!! It downloads the update then disappears and then my iphone turns off and disconnects from itunes! what do i do? :confused:
     
  5. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #5
    Kick it out of recovery with tiny umbrella or something similar.
    Are you sure you're entering DFU? Your screen is black and everything?
     
  6. james079 thread starter macrumors newbie

    Joined:
    Apr 25, 2011
    Location:
    Canada
    #6
    So i officially figured out how to fix my iphone and it is now working as well as ever! To answer the question, yes i was in dfu mode the screeb was black. But thats not what fixed my phone. When i went to restore it i would hold shift+click restore, thus bringing up the option to select the restore. I continually was trying to restore using the ipsw restore i downloaded and used to jailbreak my iphone in the first place. But it suddenly dawned on me that apple had to have its own downloaded ipsw restores for my iphone somewhere on the computer and that they had to work...so i searched them up found them and selected firmware 4.3...clicked restore and what do you know...it worked!!! my iphone is now currently upgrading to 4.3.2 (after upgrading to 4.3 first). PROBLEM SOLVED!!!! :D :D

    Thanks for the help anyways guys! :D
     

Share This Page