Need help setting up MAMP

telecarver1

macrumors newbie
Original poster
Jan 10, 2010
18
0
I am trying to install MAMP on my IMAC running OS10.10.5. I tried to use the instructions from this link: https://codex.wordpress.org/Installing_WordPress_Locally_on_Your_Mac_With_MAMP

When I get to the instruction: Once the MAMP servers start, the MAMP start page should open in your default web browser. If not, click on "Open start page" in the MAMP window. Once that's open, select phpMyAdmin from the webpage.
Under "Create new database", enter in a database name such as "wordpress", and press "Create." No need to choose an option for "collation" : it will automatically be assigned by MySQL when the database tables are created, during the WordPress installation."

The choice to "select phpMyAdmin from the webpage” does not exist. I haven’t been able to find an online tutorial for setting up MAMP 4.1.1

Please help. Thank you!
 

2457244

macrumors regular
Jul 20, 2015
238
139
This page doesn't start automatically anymore. Now you have to press the starting page (by clicking on the globe icon) in the MAMP app. You'll see a page pop up in your browser that looks like the MAMP website but it's not really. In the menu bar on the top you can select PHPmyAdim via the drop down menu.

Those Germans making the MAMP app are a bit crazy. It's also the only Mac app in the world without a close button on the window.
 

telecarver1

macrumors newbie
Original poster
Jan 10, 2010
18
0
This page doesn't start automatically anymore. Now you have to press the starting page (by clicking on the globe icon) in the MAMP app. You'll see a page pop up in your browser that looks like the MAMP website but it's not really. In the menu bar on the top you can select PHPmyAdim via the drop down menu.

Those Germans making the MAMP app are a bit crazy. It's also the only Mac app in the world without a close button on the window.
I tried that but the option is grayed out.
 

2457244

macrumors regular
Jul 20, 2015
238
139
Is it just a grey (bad UI) button or not clickable at all?

---

These are the steps.

1) check if both servers are running
2) click the globe 'WebStart' button



3) Click Tools > phpMyAdmin (nav bar)



4) Create a new database name. It's all you need to do, don't change any settings or what. Just click New database, type your database name and click Add. You're done.

5) Install WordPress, when the installer asks for the database info. you'll type the same database name + root + root for username and password. Those are default settings and are totally fine because this isn't a web server, just local on your computer, no need for stronger passwords.

 

telecarver1

macrumors newbie
Original poster
Jan 10, 2010
18
0
Is it just a grey (bad UI) button or not clickable at all?

---

These are the steps.

1) check if both servers are running
2) click the globe 'WebStart' button



3) Click Tools > phpMyAdmin (nav bar)



4) Create a new database name. It's all you need to do, don't change any settings or what. Just click New database, type your database name and click Add. You're done.

5) Install WordPress, when the installer asks for the database info. you'll type the same database name + root + root for username and password. Those are default settings and are totally fine because this isn't a web server, just local on your computer, no need for stronger passwords.

The choice is greyed out so I can't click on it.
Screen Shot 2017-02-22 at 1.53.47 PM.png
 

2457244

macrumors regular
Jul 20, 2015
238
139
Looks like your computer or MAMP is using an old version of PHP.

When you click Preference in MAMP what version do you see here?
 

jjspelman

macrumors newbie
Mar 2, 2017
2
1
Florida
I had the option of 7.0.13 or 7.1.0 as well and had to select the older version. Then I could select phpMyAdmin from the Tools menu.


Looks like your computer or MAMP is using an old version of PHP.

When you click Preference in MAMP what version do you see here?
 
  • Like
Reactions: SimonG50
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.