Need help solving a mystery : Macbook does not like Intel Compilers

Discussion in 'Mac Programming' started by Jenheta, Jul 14, 2008.

  1. Jenheta macrumors regular

    Joined:
    Mar 18, 2008
    #1
    Hi all,

    I do not want to write a long post here but I really need some enlightenment about a strange problem.

    My Macbook came with Tiger and Xcode 2.4. Being a Fortran programmer, I installed Intel compilers without much hassle. Then Leopard arrived but I decided to not upgrade until receiving the green light from Intel (for months their compilers were broken for first-time Leopard users). A few months back most of issues seemed to be gone (I successfully installed the new compilers on 3 Mac Pros and 1 Intel iMac) and I was able to upgrade my Macbook to Leopard and the new compilers.

    Here starts the drama : last week I had to upgrade my hard drive so I backup everything and did a clean Leopard install on a new and bigger HD (Hitachi 200Gb 7200rpm). Everything went fine except the fortran/C compilers. The error message I get is unique (try Google) :

    ifort: error fatal_error_terminated: Fatal error in /opt/intel/fc/10.1.014/bin/ifortia32, terminated by segmentation violation

    (I got similar message if I setup 64 bit compiler)

    I can not compile anything. Even a simple hello.f. I even update to 10.5.4 but nothing changed. In fact, it was so frustrating that I decided to do another clean install of Tiger. Yes, I downgraded Mac OSX to 10.4, downloaded the old Fortran compiler (the one I had) and guess what ? I got the SAME message.

    I triple checked my shell environment, looked over all libraries but nothing seems wrong. The ONLY thing that caught my attention was during the installation, when I selected to format the new disk using HFS+ journaled (non case sensitive). I do not believe that my old original drive had a case sensitive system but I did not checked it.

    If you can help, it would be very much appreciated !
     
  2. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #2
    Which version of Xcode are you running? The Intel compilers do not support Xcode 3.1 yet, you need to use Xcode 3.0.

    Also have you got the latest patches for the Intel compilers at all, or are you just running the version you got at the time?
     
  3. Jenheta thread starter macrumors regular

    Joined:
    Mar 18, 2008
    #3
    Hi,

    Under Tiger I tried ifort using Xcode 2.4 and 2.5. Under Leopard I tried Xcode 2.5 and 3.0.
    All compiler versions were taken directly from Intel website.

    I just checked the log file which contains some hint about the problem. I am trying
    to decipher it now...could it be a memory problem ?


    Process: ifortia32 [441]
    Path: /opt/intel/fc/10.1.007/bin/ifortia32
    Identifier: ifortia32
    Version: ??? (???)
    Code Type: X86 (Native)
    Parent Process: ifortbin [440]

    Date/Time: 2008-07-14 10:04:53.262 -0500
    OS Version: Mac OS X 10.5 (9A581)
    Report Version: 6

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x000000002820659e
    Crashed Thread: 0

    Thread 0 Crashed:
    0 ifortia32 0x0006ccf4 l_master_list_lfp + 297

    Thread 0 crashed with X86 Thread State (32-bit):
    eax: 0x28206572 ebx: 0x00068cfe ecx: 0x282065a2 edx: 0x00000002
    edi: 0x0080eed3 esi: 0x00000000 ebp: 0xbfffbfd8 esp: 0xbfffaf80
    ss: 0x0000001f efl: 0x00010202 eip: 0x0006ccf4 cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037
    cr2: 0x2820659e

    Binary Images:
    0x1000 - 0x1ddfe2 +ifortia32 ??? (???) /opt/intel/fc/10.1.007/bin/ifortia32
    0x266000 - 0x266ffd libmx.A.dylib ??? (???) /usr/lib/libmx.A.dylib
    0x8fe00000 - 0x8fe2d883 dyld 95.3 (???) <81592e798780564b5d46b988f7ee1a6a> /usr/lib/dyld
    0x90003000 - 0x90011ffd libz.1.dylib ??? (???) <5ddd8539ae2ebfd8e7cc1c57525385c7> /usr/lib/libz.1.dylib
    0x90655000 - 0x9067ffef libauto.dylib ??? (???) <d468bc4a8a69343f1748c293db1b57fb> /usr/lib/libauto.dylib
    0x906da000 - 0x906e1fe9 libgcc_s.1.dylib ??? (???) <f53c808e87d1184c0f9df63aef53ce0b> /usr/lib/libgcc_s.1.dylib
    0x92edd000 - 0x92edefef libmathCommon.A.dylib ??? (???) /usr/lib/system/libmathCommon.A.dylib
    0x94211000 - 0x94349ff7 libicucore.A.dylib ??? (???) <afcea652ff2ec36885b2c81c57d06d4c> /usr/lib/libicucore.A.dylib
    0x948f6000 - 0x9497ffff com.apple.framework.IOKit 1.5.0 (???) <5d9b85c55183f9732eb9efc38d18ba53> /System/Library/Frameworks/IOKit.framework/Versi
    ons/A/IOKit
    0x94e11000 - 0x94ef0fff libobjc.A.dylib ??? (???) <5eda47fec2d0e7853b3506aa1fd2dafa> /usr/lib/libobjc.A.dylib
    0x95559000 - 0x956b3fe3 libSystem.B.dylib ??? (???) <8ecc83dc0399be3946f7a46e88cf4bbb> /usr/lib/libSystem.B.dylib
    0x95f4b000 - 0x95fa8ffb libstdc++.6.dylib ??? (???) <04b812dcec670daa8b7d2852ab14be60> /usr/lib/libstdc++.6.dylib
    0x966c2000 - 0x967f4fe7 com.apple.CoreFoundation 6.5 (476) <8bfebc0dbad6fc33bea0fa00a1b9ec37> /System/Library/Frameworks/CoreFoundation.framework
    /Versions/A/CoreFoundation
    0xfffe8000 - 0xfffebfff libobjc.A.dylib ??? (???) /usr/lib/libobjc.A.dylib
    0xffff0000 - 0xffff1780 libSystem.B.dylib ??? (???) /usr/lib/libSystem.B.dylib
     
  4. Sayer macrumors 6502a

    Sayer

    Joined:
    Jan 4, 2002
    Location:
    Austin, TX
    #4
    Sounds like the HD has a few bad sectors perhaps. Since that is the only component that is new, I'd suspect it. Or perhaps a bad ram module. I'd try to get a different HD, tell the store you were getting a lot of bad sector errors.

    If you have two sticks of RAM try taking one out and seeing if the error goes away. If it doesn't, put the first stick back in and take the other one out and try again. If the error goes away then the stick of RAM you took out is bad enough to cause that error/crash. Turn the laptop off before removing RAM, btw.

    I once repaired a laptop with a random crashing bug that turned out to be one of two RAM sticks. The problem was that the sticks worked fine on their own, but in the system together they went into dual-channel mode and only then would one stick of the two have errors causing crashes.
     
  5. Jenheta thread starter macrumors regular

    Joined:
    Mar 18, 2008
    #5
    Thank you for the reply.
    I am trying something now but your suggestions sound very good.
    Later today I will give a shot (yes, there are two sticks of memory
    and I can easily check your idea). Actually, I have TechToolPro.
    I have never used this program (got from MacHeist deal) but maybe
    it could scan the HD surface or do a memory test, right ?
    Thanks again,

    J.

     

Share This Page