Need Help! Stuck at "Select CD-Rom Boot Type"

Discussion in 'Windows, Linux & Others on the Mac' started by riemeeer, Feb 5, 2011.

  1. riemeeer macrumors newbie

    Joined:
    Feb 5, 2011
    #1
    Hi,

    So today I decided I wanted to install Windows 7 on my iMac. However, bootcamp didnt work so I decided to reboot the computer and start it up with the CD I had inserted (it's the Windows 7 installation CD that was delivered together with my Dell laptop).
    So here's what I saw on the screen:
    White -> Black -> 1. 2. Select CD-ROM Boot Type

    My keyboard doesnt seem to be working at all, launching in safe mode doesnt work and I don't know how to get the CD out, other than pressing the button for it. I have no clue what the specs are, I'd check but the computer won't start up. :p

    Thanks in advance for any help!
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Have you tried any of these steps?



    OEM CD/DVDs don't work on other computers, you need to get a real Retail copy of Windows.

    Or you might try your luck using MRoogle.

    Btw, did you try to hold down the OPTION key during startup to select what to boot from?
     
  3. riemeeer thread starter macrumors newbie

    Joined:
    Feb 5, 2011
    #3
    Hmm, what's that option key you're talking about?
    I'll check out the links, thanks!
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
  5. riemeeer thread starter macrumors newbie

    Joined:
    Feb 5, 2011
  6. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #6
    Sounds like you also may be installing Windows 7 64 bit on an unsupported, yet fully capable iMac. If so, you may also need to look up "jowie's method" for getting around the limitations of the older Macs EFI32.

    B
     
  7. JamesRC macrumors newbie

    Joined:
    May 14, 2011
    #7
    Last weekend I had the same problem. I read all the threads that everyone came up with and found a solution that no one has presented. But before I share it with you, let me share the two good points that I did find in all the threads.

    First, the root problem is that there are two boot sectors on the install disk for Windows 7 x64. I don't know all the details about this but this is the reason the computer is asking you to select either the first or the second boot sector.

    Second, the solution that all the threads present tells you how to burn a CD with only one boot sector. I'm sure that will work if you can make it work but there is an easier way.

    The best solution that I've found to this problem is a very simple one. Remember when you had to hold down the 'F8' or 'delete' key to open up the BIOS? We’ve all done this millions of time (right?). Well I tried holding down the '1' key and the computer recognized it but didn't act on it; the same thing happened with the ‘2’ key - nothing. With partial success, I tried holding down both the '1' key and the 'enter' key to see if that would work - and it did!!! Happy Days 

    So, you can do it the hard way (make a CD with only one boot source – follow the threads if you can) or the easy way. Just hold down both the '1' & the 'enter' key at the same time when the mac OS restarts and begins installing your Windows 7 x64 into the bootcamp partition.

    The computer will not wait for you to press '1' or 'enter' so you have to have them already pressed and the computer will recognize these inputs at its own speed. Apparently, the software writers at Apple forgot that we PC users are a bit slow. So perhaps they can fix this bug with their next upgrade to the bootcamp software. Otherwise everything else works fine.

    I did not try, however, to use the method of holding down both the ‘2’ and the ‘enter’ keys. Since I was successful in using the ‘1’ and ‘enter’ keys, I did not bother to explore the other option. You try it and tell me how good/bad it works.

    One more word, I had another problem with my Bluetooth mouse and spent hours trying to find out why my mouse wouldn't work. If you have this problem, turn off your mouse in the mac OS and then turn it on in the Windows 7 x64 OS. Afterwards turn it on in the mac OS and you can use it in both. Weird, I know. And if your screen resolution is poor, don’t forget to run your Windows 7 updates. It will install a better driver.

    Have fun! :)

    PS I have been working with computers since the 1980s. I used to format hard drives, fdisk them, partition drives, etc., back in the good old days when you had to park the hard drive read/write head before turning it off (otherwise the head would bounce and damage the disk; today they automatically park the head). I've been imaging hard drives for work and for play for decades and this was the second time I replaced my hard drive for my macbook pro (I am now the proud user of a terabyte drive) with a bootcamp partition. So when I searched the web for a solution, none of the solutions I found were any good.

    I tried making my own disk by following the advice I found on the web but I had to rely on Parallels in my mac partition with Windows 7 to make it work. However, the stupid drive wouldn't write to my DVD, which seems to be a common problem. Because of this, I had to find another solution, which led to the simple fix noted above. Just hold down two keys – go figure!

    So be sure you search the known knowledge base and try it before giving up (don't give up) and then see if there isn't a simpler solution. I hope my discovery works for you and perhaps you'll make many more discoveries that will work for all the rest of us. Happy Computing :)
     
  8. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
    #8
  9. ixobelle macrumors newbie

    Joined:
    Jun 18, 2012
    #9
    worked awesome on a x64 windows 8 install DVD.

    Cheers!
     
  10. StuckOnPrompt macrumors newbie

    Joined:
    Nov 17, 2012
    #10
    ixobelle, you got it to work?

    I tried all combinations of pressing 1 + Return:

    - rapid firing both keys
    - holding both at the same time
    - switching between both options above,

    and the most I can get is that the number 1 appears at the prompt, but that's it.

    how did you get it to work?
     
  11. jdryyz macrumors regular

    jdryyz

    Joined:
    Jun 12, 2007
    #11
    Holding own 1 and Enter right when the system reboots to a black screen is what got it to work for me.

    I have a Windows 7 64-bit Ultimate install disc.
     
  12. Jsunnb macrumors newbie

    Joined:
    Mar 27, 2010
    #12
    I'm having the same problem. If I start holding them down on the white screen I get nothing. But if I start right when it turns black I can get the 1 in there. But that's it. What is the trick for getting the 'enter' and 1 to both work?
     
  13. judsonb macrumors newbie

    Joined:
    Jun 4, 2013
    #13
    stuck with blinking "1"

    I am having this same issue... I tried an external usb keyboard and got the same results...

    any ideas or workarounds???

    thanks!
     
  14. aijim macrumors newbie

    Joined:
    Jul 5, 2013
    #14
    Yes i have,
    I installed Windows 8 on my mac mini 1,1,I had the same headache.

    until i use http://refit.sourceforge.net/ refit can also do triple boot.

    lets work on, install refit in your mac os x, use a pc with windows to use pro Power iso, it has a tool to create a pendrive bootable, use a windows 8 iso, or windows 7. refit will show a windows usb boot when the machine boot to select wich one. and just select. use bluetooth keyboard , my keyboard usb couldnt move the set bar. cheers from Brazil
     

Share This Page