Need help, stuck at "update needed" login screen

Discussion in 'Mac Pro' started by GMunroe, Oct 30, 2013.

  1. GMunroe, Oct 30, 2013
    Last edited: Oct 30, 2013

    GMunroe macrumors member

    Joined:
    Mar 24, 2012
    #1
    Having my first major Mac Pro issue. I am currently locked out of my computer, and I haven't a clue how to get it back working. I think it's "bricked" but I can't be sure.

    I have recently installed Mavericks into my 5,1 Mac Pro, and ok'd the new icloud "keychain" and when working last night I had a freeze up in my System pref pane, (seemingly because of a hiccup in Hazel) that it would not display, as did my Finder somewhat. After running a repair permissions finder was still frozen as was system pref pane.

    I set the mac to reboot before bed, and whatever caused the freeze up had the mac not complete its reboot cycle as it remained where I left it last night. Hung. So I did a manual power down, and reset the PRAM hinting this would fix the situation. Unfortunately when the Mac booted up I was presented with this login screen that does not accept my password. just grey with a default icon and states "update needed". I have tried just about everything to bring it back, but nothing seems to work. It boots, and before the keyboard can register for me to go into recovery mode it defaults to this screen. It stays like that for about five minutes then shuts itself off again.

    I even removed the boot drive, and it still get the screen, I am out of options.

    Do I need to shop for a new mac, or is there a fix for this. :confused:

    Edit: many posts I have read stated that it could be the cause of FileVault. Unfortunately, it isn't turned on.
     
  2. GMunroe thread starter macrumors member

    Joined:
    Mar 24, 2012
    #2
    Some progress, I think it may be the Bluetooth keyboard making it unable to get into recovery mode.. Plugged in a USB mouse, and tried several times to boot and finally got to recovery mode... Reinstalling from time machine. Hopefully that will do the trick..

    While in recovery mode I verified that the firmware password was not enabled. (This was another theory). Also, in the grey "update" login screen, clicking on the question mark in the password box gave no mention of what the problem was or any hint.
     
  3. GMunroe thread starter macrumors member

    Joined:
    Mar 24, 2012
    #3
    Fixed. Reinstall + Time machine. I'd delete this thread if I knew how.

    Only thing I can think of causing the problem was an issue with the combo of hard reset -> PRAM reset and my Velocity card for the Crucial M4.
     

Share This Page