Need help, "This device is not eligible for the requested build"

Discussion in 'Jailbreaks and iOS Hacks' started by Justinlai5, Jul 21, 2011.

  1. Justinlai5 macrumors newbie

    Joined:
    Apr 4, 2010
    #1
    Hi all,

    I am currently receiving an error on my iPhone 3GS. It originally came with 4.3.4. After jailbreaking through redsn0w, (and switching to iPad baseband), I was stuck in the recovery loop after downgrading to 4.3.3. So I created a custom 4.3.3 IPSW through PwnageTool, put it in pwned DFU mode with redsn0w, then loaded the custom IPSW to iTunes; I was met with this error:

    "This device is not eligible for the requested build"

    Any help? :(
     
  2. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Do u have Shsh blobs for 4.3.3? U need to run tu afaik
     
  3. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #3
    If your phone came with 4.3.4 then it's unlikely it will have 4.3.3 shsh saved (ie unless it's a refurbish and previous owner saved it). If you don't have 4.3.3 shsh saved then you won't be able to downgrade it.

    Try it with another computer. I had similar problem and using another computer did the trick.
     
  4. bjornm macrumors member

    Joined:
    Jun 20, 2008
    #4
    I have a similar problem and would also appreciate some help.

    The facts
    1. I have a 3GS
    2. I have the iPad baseband installed
    3. I do not have any SHSH blobs
    4. I am stuck in recovery loop
    5. When have tried to restore custom 4.3.3 and 4.2.1 but both failed. Restore was done on Lion and iTunes 10.4

    In the ideal scenario I would like to end up with an unlocked iPhone but right now I would settle with a working iPhone.
     
  5. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #5
    I doubt they would start shipping 3GS with 4.3.4 so early.. Did u buy it used?
     
  6. Justinlai5 thread starter macrumors newbie

    Joined:
    Apr 4, 2010
    #6
    I got it secondhand
     
  7. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #7
    Try running tinyumbrella :)
     
  8. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #8
    There is no need to use both pwnage tool and redsn0w. Pwnage tool not only creates the custom firmware it also puts the phone in pwned DFU and you then just use itunes and shift restore. As others have already said you need SHSH to go to custom 4.3.3.

    A simple trick to use is after you get into pwned DFU close pwnage tool open itunes and open Tiny umbrella. Do not start TSS on TU just open it. This will automatically point your host file to Cydia and if it has SHSH you will restore to the custom firmware. If it still fails you do not have SHSH on Cydia.
     
  9. Justinlai5 thread starter macrumors newbie

    Joined:
    Apr 4, 2010
    #9
    1. Since I got it 2nd hand (restored to 4.3.4) TU will do me no good since I have no 4.3.3 shsh blobs saved :(
    2. After jailbreaking w/sn0wbreeze, it failed about 3/4 through, and everytime I boot, I am left with a white screen.
    3. iTunes says that my iPhone isn't eligible for any custom ISPWs even after pwned DFU mode (I tried custom 4.3.3 and normal 4.3.3) , and won't accept normal 4.3.4 either in normal recovery.

    Anyone have a solution? I tried fixrecovery / recboot , didn't work.
     
  10. himni macrumors regular

    Joined:
    Sep 24, 2009
    #10

    I am pretty sure that if you are running the iPad BB then the phone won't boot unless your are jailbroken.

    Did you try running tinyumbrella to see if any SHSH were saved for the phone?

    If no then you should try running one of the beta jailbreaks for 4.3.4.
     

Share This Page