pdafan

macrumors member
Original poster
Aug 2, 2011
99
13
I have a locked iPhone 3GS.
New BootRom: 359.3.2
Baseband: 05.11.07 (eligible BB for unlock)
Current version: iOS 4.1
Platform: Lion 10.7.2

With Ultrasn0w 1.2.5, I would be able to unlock it on iOS 5.0.1.
Before that, as we all know, I need to jailbreak it first on iOS 5.0.1.

With Redsn0w 0.9.9b9d, I successfully created a custom IPSW (NO_BB_iPhone2,1_5.0.1_9A405_Restore.1.ipsw.) from original iPhone 3GS 5.0.1 IPSW.

Went into Pwned DFU mode and tried to restore the custom IPSW with iTunes 10.5.1.
Without TinyUmbrella (v5.10.01), iTunes refused to proceed with the restoration on the custom IPSW.
With TinyUmbrella, TSS server on, able to bypass Apple (gs.apple.com). Proceeded one step further but failed on Error 11. (due to absence of BBFW file).

Problem is, I need the BBFW file to be removed so that I can preserve my baseband for the unlock. Therefore I cannot put back the BBFW file to overcome Error 11.

Now I am stuck. Can someone offer me some solutions to complete the jailbreak? I have read quite extensively to self-help. Is there something I am still missing?

Thanks much.
 

freedom8

macrumors newbie
Dec 21, 2011
9
0
try make custom ipsw by sn0wbreeze v2.8b11, I believe it would not change your BB. Then restore the custom ipsw by itune 10.5. I just succeed to jailbreak and unlock using this way on my iPhone 3Gs new bootrom v5.0.1 baseband 05.16.00. see the post
 

pdafan

macrumors member
Original poster
Aug 2, 2011
99
13
try make custom ipsw by sn0wbreeze v2.8b11, I believe it would not change your BB. Then restore the custom ipsw by itune 10.5. I just succeed to jailbreak and unlock using this way on my iPhone 3Gs new bootrom v5.0.1 baseband 05.16.00. see the post


Hi,

Great info and advice. Will try it out soonest possible.
Thanks!
 

JunkyDog

macrumors 6502
Sep 17, 2011
274
0
First you need to update iTunes to latest version around, then you need to edit your host file and remove everything that points to iTunes servers. Save the file, and dont start TU, just press option + restore in iTunes, and select your custom IPSW file. I did that in my 3GS phone, and it worked just fine. Except i will wait for the untethered JB to come out, and it is very soon, so i just want you to know..
 

srprentice

macrumors newbie
Dec 27, 2011
1
0
Thank you!

First you need to update iTunes to latest version around, then you need to edit your host file and remove everything that points to iTunes servers. Save the file, and dont start TU, just press option + restore in iTunes, and select your custom IPSW file. I did that in my 3GS phone, and it worked just fine. Except i will wait for the untethered JB to come out, and it is very soon, so i just want you to know..

Okay, I was on 4.2.1 on my iPhone 4 with 01.59.00. I went to do the update using redsn0w and my iPhone got locked. No matter what shift+click restore I did, it would give me error 11. I did what you said, edited the hosts file (I didn't before, as I though TinyUmbrella already had) and now it WORKS!

I wish I could hug you right now!

THANK YOU!!!!
 

dt408sc02

macrumors newbie
Sep 13, 2010
15
0
Okay, I was on 4.2.1 on my iPhone 4 with 01.59.00. I went to do the update using redsn0w and my iPhone got locked. No matter what shift+click restore I did, it would give me error 11. I did what you said, edited the hosts file (I didn't before, as I though TinyUmbrella already had) and now it WORKS!

I wish I could hug you right now!

THANK YOU!!!!

I'm jailbroken on 4.3.3 with iPhone 4 GSM, and I got Error 11 after trying to restore to custom no BB 5.0.1 firmware in DFU mode. Tried running TSS server with TinyUmbrella while restoring, but it still wouldn't update.

What changes did you make to your hosts file to fix it?
 

pdafan

macrumors member
Original poster
Aug 2, 2011
99
13
First you need to update iTunes to latest version around, then you need to edit your host file and remove everything that points to iTunes servers. Save the file, and dont start TU, just press option + restore in iTunes, and select your custom IPSW file. I did that in my 3GS phone, and it worked just fine. Except i will wait for the untethered JB to come out, and it is very soon, so i just want you to know..

Brilliant advice! I have waited for the untethered jailbreak and went for it today according to your steps. It worked beautifully!

Thanks!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.