Need help to kill smooth scrolling in Chrome

Discussion in 'OS X Mountain Lion (10.8)' started by shznit, Nov 14, 2012.

  1. shznit, Nov 14, 2012
    Last edited: Nov 24, 2013

    shznit macrumors member

    Joined:
    Apr 4, 2010
    #1
    So Mountain Lion removed the toggle for smooth scrolling in System Preferences, General. I just found out today when I purchased a 13" rMPB and wanted to kill it so I could scroll lag-free with spacebar in Chrome. I googled the issue and found the following commands:

    defaults write -g NSScrollAnimationEnabled -bool NO
    defaults write -g NSScrollAnimationEnabled -bool false

    They worked, but only in Safari. I'm looking for someone who knows OSX better than I to help me figure this out. I know there has to be a way because I also bought a MacBook Air a few months ago with Lion on it and immediately unchecked smooth scrolling. After updating to Mountain Lion, the setting stuck and smooth scrolling is still disabled in Chrome exactly like in Safari, so the setting must be somewhere.
     
  2. shznit thread starter macrumors member

    Joined:
    Apr 4, 2010
  3. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #3
    Try this, to force Chrome to re-read the settings: Click the wrench (21-) or three bars icon (22+) and open the Settings. Click Show advanced settings. Add a new user. Set this new user as the default user. Restart Chrome, and set up sync again if need be. If the problem is now gone, delete the old user. Otherwise, set the old user as the default, restart Chrome again, and try something else.
     
  4. Simplicated macrumors 65816

    Simplicated

    Joined:
    Sep 20, 2008
    Location:
    Waterloo, Ontario, Canada
    #4
    Interestingly, it works in Chrome 23, but not in my Safari. :confused:
     
  5. colloc macrumors member

    Joined:
    Jul 27, 2012
    #5
    Do you experience lags on your rMBP?
     
  6. shznit, Nov 17, 2012
    Last edited: Nov 17, 2012

    shznit thread starter macrumors member

    Joined:
    Apr 4, 2010
    #6
    here and there. Chrome definitely lags on some sites more than Safari, but it's not a deal breaker. The screen is so awesome that I can overlook the occasional lag.

    That said, tapping spacebar quickly scrolls down a whole page and if it's not smooth it really annoys me (even when it's smooth the blur is annoying), not to mention it ramps up the cpu wasting battery, which is why I always disable smooth no matter what pc I'm using.

    didn't work. I wonder why the setting stuck when I unchecked smooth scrolling 10.7 before upgrading to 10.8. Taking these toggles away is just ridiculous.
     
  7. shznit thread starter macrumors member

    Joined:
    Apr 4, 2010
    #7
    resurrecting this thread in hopes of a solution.
     
  8. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #8
    Looks like newer versions of Chrome honor the smooth scrolling system setting (that also affects Safari). Disabling this ought to do the trick.
     
  9. maxosx macrumors 68020

    Joined:
    Dec 13, 2012
    Location:
    Southern California
    #9
    I've had great experiences with the latest rev of Chrome on my 15" MBP r. Same for Firefox. Only Safari is a bit irratic, a problem Apple's sure to address.
     
  10. shznit thread starter macrumors member

    Joined:
    Apr 4, 2010
    #10
    I am running the newest version of the dev channel and smooth scrolling is still enabled despite the terminal command. I tried uninstalling and re-installing (I deleted every chrome-related file I could find) but still no dice.

    Are you saying that when you press spacebar in chrome it doesn't smooth scroll for you?
     
  11. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #11
    I never tried spacebar-scrolling until you mentioned it :eek:
     
  12. shznit, Feb 17, 2013
    Last edited: Feb 17, 2013

    shznit thread starter macrumors member

    Joined:
    Apr 4, 2010
    #12
    Try it in Safari and Chrome if you don't mind. My eyes are trying to focus on the blurry text while it's moving and it leads to strain. With smooth scrolling disabled the next page appears immediately.
     
  13. johnsawyercjs macrumors member

    johnsawyercjs

    Joined:
    Feb 27, 2007
    #13
    I know this is an old thread, but here's the official word on this from Google, at https://code.google.com/p/chromium/issues/detail?id=102099:

    "Smooth scrolling isn't quite there yet on windows and linux, which is why it's [an option] on about:flags. It's fully functional on mac, which is why it's on by default." [and which is why they no longer include a flag to turn it off]

    They also say that Chrome honors the system default for smooth scrolling, but starting with Mountain Lion, OS X no longer has a prefpane setting to turn off smooth scrolling, and the command line method to turn it off (defaults write -g NSScrollAnimationEnabled -bool NO) doesn't have any effect on Chrome, because Chrome uses its own smooth scrolling code.
     
  14. shznit thread starter macrumors member

    Joined:
    Apr 4, 2010
    #14
    No worries, I was actually going to post an update. I finally figured out how to kill it!

    I ran the terminal command on a fresh installation of Mavericks beta and final before installing Chrome and rebooted. Then I installed Chrome and smooth scroll was gone.
     

Share This Page