Need Help Troubleshooting G4 Power Mac

Discussion in 'PowerPC Macs' started by harcosparky, Apr 21, 2008.

  1. harcosparky macrumors 68020

    Jan 14, 2008
    Wow ... our first failure with a Mac and it is an older G4 Powermac.

    It will not boot up.

    The only symptom I can give is .....

    1) When powered up we get the CHIME sound.
    2) Nothing shows on display.
    3) Keyboard shows no response ( i.e. when pressing CAPSLOCK it does not light up )

    In the past we have had issues with this unit. It would boot up and go to a white screen. Sometimes it would go to the point where it shows the :apple: and go to white screen, other times it would go to :apple: show the spinning pinwheel then go to white screen. WHen it did this we would power down and restart, sometimes it took on restart, other times more. Yesterday it finally failed to boot.

    I am thinking video card, but not sure if there is something else I can check first.

    Any ideas?

  2. Sorkvild macrumors 6502

    Feb 23, 2007
    Have you tried another display to see if the same thing happens? If you have the DVDs it came with, try running the hardware test.
  3. tersono macrumors 68000


    Jan 18, 2005
    Hmm - have you tried re-setting the PRAM? (Boot holding down CMD-OPT-P-R - wait for third 'bong' before releasing). It probably won't help, but it's the first thing to check.

    The non-responsive keyboard suggests to me that the problem is a little larger than gfx card, but try removing the video card - if that's stopping boot, the machine should get past there and allow the keyboard to become active. If that happens, then all you need to do is replace the card. If, however, you still get no Caps Lock response, then I'd have to suspect a faulty logic board.

Share This Page