Need help troubleshooting this - iMovie will not open

Discussion in 'Mac Apps and Mac App Store' started by PicnicTutorials, Mar 5, 2014.

  1. PicnicTutorials macrumors 6502a

    PicnicTutorials

    Joined:
    Dec 29, 2013
    #1
    All of a sudden it will not open. I quit the app and restarted. I restarted the computer. I deleted and redownloaded iMovie. I checked disk permissions. It wont open. I some times will open if i click on it twice but if it does it is corrupt and does not load with any options or its regular look - basically a white screen. Any thoughts how to fix this?
     
  2. Brian33 macrumors 6502a

    Joined:
    Apr 30, 2008
    Location:
    USA (Virginia)
    #2
    That's odd!

    I would try removing or renaming the iMovie preferences file. It's read during app startup and maybe something in there is causing the behavior. Removing it will cause iMovie to create a new one with default values, but you'll lose whatever preferences you've set in iMovie.

    Mine is here:
    /Users/brian/Library/Preferences/com.apple.iMovieApp.plist

    (However I'm not running the very latest iMovie so yours could have a different name.)
     
  3. PicnicTutorials thread starter macrumors 6502a

    PicnicTutorials

    Joined:
    Dec 29, 2013
    #3
    Thanks bud for the response. After opening and closing it a hundred times and running cleanmymac it finally opened correctly and does so each time now. I'm guessing it was that corrupted file you mentioned and running cleanmumac may of deleted it's cache thus creating a new file to pull from. Maybe
     

Share This Page