Need help upgrading to OS4.2.1

Discussion in 'Jailbreaks and iOS Hacks' started by PinoySaMI, Dec 3, 2010.

  1. PinoySaMI macrumors member

    PinoySaMI

    Joined:
    Aug 9, 2010
    #1
    I have an unlock 3GS with firmware 05.13.04 and OS 4.0.2. I tried to update it to new OS 4.2.1 but I got this error message, "COULD NOT RESTORE BECAUSE THE FIRMWARE FILE IS NOT COMPATIBLE".

    Could someone help me?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    How could the error message not tell you what's wrong. You need to get the proper firmware for your 3Gs. You need the iPhone 2,1 one.
     
  3. SavMBP15 macrumors 6502

    Joined:
    Mar 26, 2010
    #4
    Make sure you do not update your baseband to 06.15 (iPad). You have an unlockable baseband so you need to preserve it with a custom IPSW created by Pwnage.
     
  4. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #5
    Don't update to 4.2.1, you'll lose your unlock then the complicated issues come into play.

    Read the "Ultra Recycle" post on the iPhone Dev-Team Blog ----> www.blog.iphone-dev.org
     
  5. PinoySaMI thread starter macrumors member

    PinoySaMI

    Joined:
    Aug 9, 2010
    #6
    That's why i posted my problem. I do not want to screw-up my unlocked iphone. This is the only phone i have.

    I already screw up my daughter's iphone 3GS by accidentally upgrading to OS 4.2 and in turn updating her BB to 05.14.04 which is not unlockable with ultrasnow right now.

    What should i do? Wait until BB 05.14.04 can be unlocked? I am really not in a hurry to upgrade my OS.
     
  6. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #7
    I would wait if I were you, unless you really need the unlock. Once you update the baseband to the iPad's 6.15.00, there is no going back. You also would not be able to to update your iPhone anymore. If you do you'll just get an error message. The only way to restore your iPhone would be to use a custom ipsw with the ipad baseband.
     
  7. PaulDoFish macrumors regular

    Joined:
    Jun 23, 2010
    #8
    I used pwnagetool to update my 3G to 4.2.1 with BB 5.13. Ultrasnow works perfectly fine. You will still have your unlock.

    I'm not sure about the 3GS though. If I were you I'd stay on 4.0.2.
    4.2 isn't that great imo unless you REALLY want to set text tones to certain contacts...
     
  8. PinoySaMI thread starter macrumors member

    PinoySaMI

    Joined:
    Aug 9, 2010
    #9
    Thank you all for the response and advice. I appreciate the help.
     

Share This Page