Need help with a startup error message, can't get into folder to sort it!

Discussion in 'Mac Basics and Help' started by MooMoo, Sep 13, 2009.

  1. MooMoo macrumors newbie

    Joined:
    Sep 13, 2009
    #1
    Hi, Im new to Macrumours, and I'm here on the recommendation of a friend. :)

    Anyhoo, I uninstalled my Lexmark printer since Snow Leopard exploded/deleted/doesnt have the drivers for my printer (another problem for another time), and ever since I've had this error message on startup:

    There are no options to fix or delete LexSleeperX.app, and I cant get into Startupitems (Despite the fact its my laptop, and Im the admin, I dont have permission to access it, lol) so I really dont know what to do.

    Any help or advice is much appriciated. :)

    (On a Macbook Pro if that makes any difference)
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    If you do not have access to it as admin, try accessing that folder as root. In 10.6, Apple made it a little more difficult to open Directory Utility and gain root access. You have to go to Accounts preferences, click Login Options, click on the Join button next to Network Account Server, then click on Open Directory Utility from the popup. Click the padlock, authenticate with your admin password, go to the Edit menu, select Enable Root User. Enter in a password and verify it. Now log out of your admin account, at at the login window you'll see an option for Other... Enter "root" without quotes for the name, and the root password you entered. Now go to the specified folder location and delete LexSleeperX.app. Log out, back to the admin, see if that fixed the issue. If it did, go back to Directory Utility and disable the root account. Remember to set the root password back to nothing (also from the Edit menu) before you disable it completely.
     
  3. MooMoo thread starter macrumors newbie

    Joined:
    Sep 13, 2009
  4. PW168 macrumors member

    Joined:
    Oct 10, 2009
    #4
    I just bought a macbook (not macbook pro) and I am having the same problem ie /Library/StartpItems/LexSleeperX.app has not been started because it does not have the proper security settings.

    My macbook has snowleopard installed. I tried to follow your instructions but I am not following. Pls help.

    Thanks in advance.
     
  5. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #5
    PW168, you only have to take the steps I provided if you can't see the contents of /Library/StartupItems as MooMoo had run into. If you can manually remove the file that won't run from that directory there is no need to enable root.
     
  6. PW168 macrumors member

    Joined:
    Oct 10, 2009
    #6
    LexSleeperX.app error message

    JediMaster

    This was your message:
    If you do not have access to it as admin, try accessing that folder as root. In 10.6, Apple made it a little more difficult to open Directory Utility and gain root access. You have to go to Accounts preferences, click Login Options, click on the Join button next to Network Account Server, then click on Open Directory Utility from the popup. Click the padlock, authenticate with your admin password, go to the Edit menu, select Enable Root User. Enter in a password and verify it. Now log out of your admin account, at at the login window you'll see an option for Other... Enter "root" without quotes for the name, and the root password you entered. Now go to the specified folder location and delete LexSleeperX.app. Log out, back to the admin, see if that fixed the issue. If it did, go back to Directory Utility and disable the root account. Remember to set the root password back to nothing (also from the Edit menu) before you disable it completely.

    My queries:
    - I am a home user so I am not networked. But I set myself up as admin so what do I need to do?
    - I also tried to follow your instructions (at root), but I don't know where to find Accounts preferences.
     
  7. slimslam macrumors newbie

    Joined:
    Aug 15, 2007
    Location:
    England
    #7
    I know this is well over a year late but I had the same problem and managed to find what was wrong so thought I should post just incase others have the same problem. You have to make sure that you select your harddrive from the Devices section on the left hand side of Finder and then select Library from here, do not select the User from Places then Library, I believe they are separate locations so you are probably looking a specific users library rather than the system library.
     
  8. BobbyLo macrumors newbie

    Joined:
    Sep 26, 2011
    #8
    Open Terminal. Once in terminal if you are admin type "open /Library/StartupItems" without the qoutes. It should open that folder and then just drag the file to the trash and empty trash. This is what worked for me. I have 10.7
     

Share This Page