Need help with external sound card (not getting 5.1 in Audio Midi Setup)

Discussion in 'Digital Audio' started by BigDaddy5, Nov 24, 2007.

  1. BigDaddy5 macrumors member

    Joined:
    Dec 6, 2006
    #1
    I'm using a sound blaster extigy, and everywhere I read says this card will work with OS X. I'm running 10.5.1, and I can only get stereo output. Does anybody have any advice to get OS X to recognize this as a 5.1 channel card? Audio MIDI Setup only shows me an option for "Stereo," and all the rest are grayed out.

    If there is no way to do that, does anybody have any suggestions for 5.1 channel cards like this one? I need to have individual outputs, so I can get traktor to run through seperate channels like this one. I did it with PCDJ on Windows before I switched to Mac, but now I'm having no luck.
     
  2. ridehard macrumors member

    Joined:
    Feb 11, 2008
    Location:
    Portugal
    #2
    same here, got the z-5500 with optical cable with mini toslink and only get the stereo. In dvd player i get 5.1 output .
    Under windows only stereo.
     
  3. AviationFan macrumors 6502a

    AviationFan

    Joined:
    Jan 12, 2006
    Location:
    Cedar Rapids, IA
    #3
    I don't know this specific sound card, but I do recall that as a general rule, 5.1 output over Toslink is possible ONLY for the DVD player because the audio is then already encoded as AC3 (Dolby Digital). Mac OS does not include a realtime AC3 encoder, so for all other purposes (other than DVDs) you'd need to have an audio interface with six separate outputs, uncompressed and typically analog.

    Maybe this helps...

    - Martin
     

Share This Page