Need help with Handbrake and MTR 3

Discussion in 'Mac Apps and Mac App Store' started by Dr. Hook, Nov 9, 2008.

  1. Dr. Hook macrumors newbie

    Joined:
    Nov 9, 2008
    #1
    I have searched everywhere to try and solve this problem and no luck so I thought I would try here. I have recently purchased the New Macbook aluminum and I am having trouble using Mac The Ripper and Handbrake. When I try to use MTR I get a "bad sectors" error message every time. When trying to use Handbrake it hangs in scanning title. I only get these problems with the new MacBook, when I use my old iBook G4 both MTR and HB work with no problems. Has anyone else experienced this problem? Any advice or help would be great. I would have tried to post this over in the Handbrake forum but I was afraid they would have called me an idiot and told me to go kill myself like they tell most of the people who ask questions over there.
     
  2. deriko100 macrumors 6502

    Joined:
    Jul 29, 2008
    Location:
    New York
    #2
    Maybe Handbrake nor MTR are supported on the new systems, you'll probably have to wait until they release a version that supports the newer systems. Or you could try they're forums, or support team.
     
  3. cdcastillo macrumors 6502a

    cdcastillo

    Joined:
    Dec 22, 2007
    Location:
    The cesspit of civilization
    #3
    Are you sure you are using same discs on the iBook and in the Macbook?

    I have had the same problems on a late 2007 MB, but I've found it depends on the DVD I'm trying to rip, not on the machine I'm using to rip it. I mean, some of my DVDs (e.g., SW's episode 3) won't rip at all in any of my machines (MB SR, PB G4, iB G4), but any other disc will do fine.

    So, have you checked with other DVD's?
     
  4. MBuco12 macrumors member

    Joined:
    Nov 2, 2008
    #4
    i have a new aluminum macbook 2.0 and have no problems with handbrake, so it is able to be used on this system. havent tried mtr though
     
  5. NC MacGuy macrumors 603

    NC MacGuy

    Joined:
    Feb 9, 2005
    Location:
    The good side of the grass.
  6. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #6
    Do the DVD's playback correctly without skipping?

    Have you tried the Snapshot version of HandBrake?
     
  7. Dr. Hook thread starter macrumors newbie

    Joined:
    Nov 9, 2008
    #7
    I have tried using the same disc on both, and have tried a couple of others. For some reason the ibook works and the macbook doesn't. I have also tried the snapshot for Handbrake and it seemed to work but when Handbrake says everything is complete I have a movie with only a minute of playback time, it seems like it is fast forwarding and and 3/4 of the screen is green. Unfortunately they do not offer support for the snapshot and they are not very helpful when it comes to asking questions. They have a great product but they don't treat people very well over at handbrake. Any other suggestions?
     
  8. tetsuo29 macrumors newbie

    Joined:
    Nov 29, 2008
    #8
    DVD Rips w/ MTR 3 & FairMount 2008 Alu MacBook

    Hey, I too was unable to rip DVDs on my new 2008 Alu MacBook until I stumbled upon a forum somewhere where it was mentioned that the Apple DVD Player needed to be opened in order to rip on these new machines. I tried it, and it works. Works with MTR 3.0r14 and FairMount.

    For best results, launch the Apple DVD Player, insert your DVD, skip past any previews to the menu, and then press the stop button. If the DVD Player is cycling through the menu screen animation, this seems to seriously impede the speed of ripping.

    Unfortunately, Popcorn 2.0.2 no longer seems to work to compress the DVD to back it up on a 4.7GB blank. After the compression is complete, it crashes when it starts to burn. Luckily, I have a copy of DVDRemaster Pro that I got in a MacHeist or a MacUpdate bundle (I lose track), and even though there was a bit of a learning curve with DVDRemaster that Popcorn didn't seem to have, once I read the documentation and got it figured out, it works great. So, now, I can backup those DVDs I don't want the kiddies to scratch.
     

Share This Page