Need Help with iMac 350 - Won't boot - No keyboard or mouse

Discussion in 'iMac' started by xmacuser, Nov 11, 2007.

  1. xmacuser macrumors newbie

    Joined:
    Nov 11, 2007
    #1
    Hello,

    I've scoured the web looking for answers, and can't find any, so maybe someone here would be kind enough to help. I'm working on an imac 350 blueberry for my sister and I'm having all sorts of trouble.

    She bought it last week, it started up (8.6 os) no problem. Powered up and down a few times, then all of a sudden, it won't boot. I'm currently getting blinking folder/happymac/question mark when trying to start up.

    Here's the big problem - the keyboard and mouse do not work now. I've tried three different mice and three keyboards and no dice with any of them. I have the 8.6 CD from her previous imac (bondi), and I can hear it spinning, but there is no way to start up from cd.

    I've also tried 2 other hard drives with the same results.

    Tried resetting CUDA on logic board, taking out battery, no change. Bought new battery- no change.

    I would love to at least get the keyboard working to see if I can even startup from cd, anyone have any clues on how to get it working? The strange thing is that the keyboard has a power on button, and it works to start the thing up, but dies when it tries to boot. Sometimes I just get a grey screen with the pointer icon, and I can move the pointer with the mouse for a second or two, then no response.

    I appreciate any help or suggestions on locating the issues!

    Thank you!
     
  2. iBob RevC macrumors newbie

    Joined:
    Oct 12, 2005
    Location:
    Cape Cod, MA
    #2
    Hi:

    If you are getting the flashing question mark, it is not finding the startup disk or system folder. (I presume you are using System 9.xx?)

    Also, I presume you are holding down the "c" key when you attempt to startup from the OS CD?

    Have you reseated or verified the ram?

    I doubt you have a faulty keyboard or mouse, and certainly not three of them. In 15 years of operating Macs, I have never had a bad keyboard, although I did have a stuck mouse button once, and it prevented computer from booting.

    Was any software upgraded or installed between the time it booted OK & then not? There were firmware updates that needed to be performed on these older imacs prior to installing a new OS-not very familiar with this aspect, but someone else might be.

    Hope this helps,

    Bob
     
  3. xmacuser thread starter macrumors newbie

    Joined:
    Nov 11, 2007
    #3
    Hi Bob,

    Thank you for your reply. The imac is running OS 8.6, and we did not try to install anything between the time it started and stopped working. I am holding down the "c" key with my fingers crossed, but since the keyboard commands are not being recognized, it won't boot up from the cd.

    I appreciate the head's up on the firmware upgrades that are needed, my original intention was to get the os up to at least 9.2.2, if not one of the X's.

    If anyone has any thoughts on why the keyboard and mouse are not functioning, I would be really grateful to hear them. The keyboard will power up the computer, but then nothing, and the light in the optical mouse shines, so I know the power aspect is working, just not the commands.
     
  4. xmacuser thread starter macrumors newbie

    Joined:
    Nov 11, 2007
    #4
    Any thoughts? I'm super open to any suggestions.

    Any hardware experts out there? If I could get some help trying to get the usb ports recognizing commands from the keyboard, I could at least take the next steps in figuring out what's going on.

    Anyone know the layout of the usb ports on the board, and if they can be fixed/replaced without replacing the entire logic board?

    I've already spent more than the computer cost to try and fix this thing, and I'm now considering switching my sister over to a PC for good (she's using a borrowed PC because her last imac literally fried on the inside).

    Please help, so I don't have to use my last resort.

    Thank you!
     
  5. iBob RevC macrumors newbie

    Joined:
    Oct 12, 2005
    Location:
    Cape Cod, MA
    #5
    What disc are you trying to boot from? And does the 350 have a cdrom drive or a CDRW drive? If it is a disc copied onto a CDRW, it will not be recognized by a mac with just a cdrom drive. You might try booting from a Tech Tools or Norton disc if you know anyone that has one. You could also try creating a startup disc on a pen drive, which would rule out a problem with the CD or CD drivers. Just throwing this out there.

    Good luck.
     

Share This Page