Need help with iMessage after activating new phone

Discussion in 'iPhone' started by Phonzoxd, Sep 19, 2014.

  1. Phonzoxd macrumors 6502a

    Joined:
    May 28, 2013
    #1
    So i put my sim in the new iphone 6+

    but now for people who also uses an iphone starts a message with me it goes to my old phone through imessage.

    The imessage wont go to my new phone unless i start a new conversation with these people. How can i fix this?
     
  2. Omniblast macrumors member

    Omniblast

    Joined:
    Jun 16, 2010
    #2
    I think you need to go to your messages setting and turn off iMessages from there. Maybe sign out of your iCloud account as well? Tell us if this works.
     
  3. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #3
    Did you upgrade your line?

    If you did then you don't need to swap sims.

    The sim included with your new phone will activate your 6.




    You want to go into your old phone, settings, messages, turn off iMessage
     
  4. reverberlayed macrumors regular

    Joined:
    Sep 5, 2014
    #4
    To be clear, did you take the old sim out of the old phone and place in the new phone or did you use the new sim?

    If you're using the new sim, try taking the old sim out of the old phone or leaving old phone off. Power cycle new phone and try again.
     
  5. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #5
    In Settings > Messages on both devices, I'd compare the Send & Receive addresses and see what the differences were.
     
  6. Phonzoxd thread starter macrumors 6502a

    Joined:
    May 28, 2013
    #6
    I took out the old sim and put into new phone cause the sim that was in the new phone is using my sisters line.

    I sent a message to everyone who uses iphone so that now when they message me itll go to the new phone. Its an inconvience but i need to make sure and do it that way.
     
  7. Skevaboy macrumors member

    Joined:
    Dec 14, 2011
    Location:
    Toronto
    #7
    Turn off Messages on the old phone, reboot phone ( i assume no sim card is in it) and the number that was linked to that phone should be gone from the "Send & Receive" setting of Messages
     

Share This Page