Need help with installer/jailbreaking

Discussion in 'iPod touch Hacks' started by hatcher146, Oct 19, 2007.

  1. hatcher146 macrumors 6502

    Joined:
    Mar 26, 2007
    Location:
    north carolina
    #1
    if anyone could help it would be greatly appreciated! :)

    i just did a full restart and installed jailbreak on the touch again.

    when i click on the installer icon...under update....there is "installer"....i installed that...and it gave me an error...when i pushed the home button...it does the little restart and then the installer icon is GONE, what do i do! this is the second time its hapend. do i have to do the jailbreaking all over again?? and should i not install "installer" anymore?

    also

    i installed summerboard once...buttt it messed up the touch it made the real iPod touch dock go to the top and it looked weird...will that happen again?

    or is summerboard just when you have alot of apps? im confused on that.

    thanks!
     
  2. yegon macrumors 68020

    Joined:
    Oct 20, 2007
    #2
    Yeah, I'm having the same problem and would be very grateful for a little help.

    I successfully jailbroke the touch via the iJailbreak gui, used the install.app a couple of times, then updated the install app itself. This caused an error, and the install app disappeared upon reboot. Aside from the absence of the install app, it is otherwise running fine ie the progs I installed (like Books for example) are still there. What do I need to do to reinstall the installer app? A visit to iphone.nullriver.com/beta/ is fruitless as they don't have a version available for 1.1.1 (which I don't understand, since it was working on my 1.1.1 until I updated).Apologies, I only got my Touch yesterday.
     
  3. holybatfart macrumors member

    holybatfart

    Joined:
    Mar 21, 2007
    Location:
    Johio
  4. cmuench macrumors member

    Joined:
    May 15, 2007
    #4
    Well I would do a full restore from itunes and reattempt the jailbreak. I jailbroke my ipod touch like 2 weeks ago though through the CLI so I have no expirence with the GUI versions that are out their. I do however have the newest version of installer.app running just fine on my touch.
     
  5. Gondry macrumors member

    Joined:
    Oct 12, 2007
    Location:
    London
    #5
    same here, lost the installer icon on my touch after the error message when updating, can see the folder in cyberduck though.

    Don't want to do a whole restore thing, how do i get the installer back?
     
  6. DaBrain macrumors 65816

    DaBrain

    Joined:
    Feb 28, 2007
    Location:
    ERIE, PA
    #6
    Bummer! This doesn't sound good. Same thing just happened to me! IM looking at the touch via Cyber Duck and I see the installer app there but it doesn't show up on main screen so I can't install or uniinstall anything now.

    Trying to figure out how to get it to show back up with out doing a restore and reinstalling jail break. Also Mobile no longer functions.

    Anyone have any ideas?
    :confused:
     
  7. yegon macrumors 68020

    Joined:
    Oct 20, 2007
    #7
    Yeah, Cyberduck shows it's clearly still there on mine too. I'm going to hold off re-jailbreaking it until someone offers a solution, as I suspect exactly the same thing will happen again. Plus, the main reason I jailbroke was for the Books application, which I thankfully installed before the install app disappeared.

    Aside from that, I've been reading ebooks for years, right back to Psion & Palm days, and I'm happy to say the Touch is easily the best reader I've ever had.
     
  8. DaBrain macrumors 65816

    DaBrain

    Joined:
    Feb 28, 2007
    Location:
    ERIE, PA
    #8
    Well I see no one came to our rescue!--)))

    Here's what happened after I wrote the above msg.

    I decided to restore ipod and re-install ijailbreak. But when attempting to restore I couldn't get itunes to offer me to restore. I think I screwed up the sequence and timing on holding down the start and home buttons on the itouch. After dissconnecting my ipod I heard the famous click noise from the ipod and lo and behold I see the spinning symbol indicating something is happening, IE: it's busy doing something just like what ya get after doing an install on the itouch or what we see when safari is busy or when our Mac boots up. Next thing ya know I have the 3.0 installer icon on my itouch! Now Finder and all is working just fine!

    Funny thing is it clearly is the new 3 installer, yet when I click on about, it still says 2.63. Yet I know it's the new installer just from seeing that it's completely restructured and reading it's welcome msg.

    Atleast it's all funtioning here now.

    How about the rest of you?
     
  9. holybatfart macrumors member

    holybatfart

    Joined:
    Mar 21, 2007
    Location:
    Johio
    #9
    I did a complete reinstall and don't know if i wanna risk another one. And i can't dl any community stuff cuz i don't see community sources. do i have to update for that?

    edit: updated just fine
     
  10. Gondry macrumors member

    Joined:
    Oct 12, 2007
    Location:
    London
    #10
    I've got the original installer back, by using cyberduck to delete the broken installer app and upload the old one from the resources folder of ijailbreak.

    everything fine again, no need to restore and copy all the music again.

    I'll ignore the upgrade option for a while
     
  11. yegon macrumors 68020

    Joined:
    Oct 20, 2007
    #11
    Hmm, I just tried that and it doesn't seem to have worked. Is it just a matter of copying resources\installer to (touch) library\ ? I did that, did a reset, and it hasn't reappeared on the screen.

    edit: scratch that. I put it in the media\install.app and it worked! Nice one! Cheers!
     

Share This Page