Need help with MacBook (laundry list of problems)

Discussion in 'MacBook' started by Ylj, Jan 31, 2012.

  1. Ylj macrumors newbie

    Joined:
    Jan 31, 2012
    #1
    I am an 8th grader working as tech at my middle school, and one of the computers that I'm working with seems impossible to use.

    I needed to add an admin account to the computer, but the system preferences on the computer had the prohibitory sign on it and would not start. (I found the system preferences app in the trash, so I can guarantee that a student had something to do with this.)

    After one day of trying to find a way to get this to work, I turned on the computer the next day, and it would not boot. After a few moments of the Apple sign appearing on the screen, it would show the prohibitory sign again, and would not load anything. I got a 10.6.7 Snow Leopard install disc and put it in the computer, but it when I got to the install page, it would say that the computer can not finish the installation (this is on the main page of the installer).

    So I got a 10.6.3 Snow Leopard disk and it started the install process. I had started this during 4th period, but when I checked on it during 6th period (after classes), it said that the installation had failed.

    I used the Disk Utility from the Mac OS X Installer disk, but it said that the Macintosh HD had no problems. I went into Restore System From Backup but it did not have any Time Machine backups.

    When I have tried to boot into Safe Mode, nothing happens and it goes to the prohibitory sign again. When I try to boot into command prompt, I get a mach_kernel error and nothing happens.
    *** Command prompt just loaded regularly, but I am unable to use the classic hacks to get in (removing applesetupdone, changing password through Localhost%, or accessing com.apple.DirectoryServices.plist).

    To add to these problems, the bottom two rows do not work, so I am using a USB keyboard. If a iBook G4 keyboard would work, that might be a start to being able to use this computer.

    ANY help is appreciated with this. Thanks.
     
  2. minifridge1138 macrumors 6502a

    Joined:
    Jun 26, 2010
    #2
    Do you know what year/model of MacBook it is?

    The install disks you're using, are they retail disks (white label) or are they system restore disks (grey label)?
     
  3. Ylj thread starter macrumors newbie

    Joined:
    Jan 31, 2012
    #3
    I do not know the year/model of the MacBook, but I will check when I am at school tomorrow.

    As for the install discs, I will also post more info about them, but the first disk I used that wouldn't work was a 10.6.7 install disk, it had a gray label on it, and it came in a white disk case that said "Everything Else" which was also with a case that said "Everything Mac". These install disks came in boxes along with a group of new iMacs, but I wouldn't know if this would make a difference for installing on an MacBook.

    The second disk that I used that failed later into the installation process was a 10.6.3 install disk, and it was a white disk with a snow leopard on the bottom right. I found the 10.6.3 disk in a computer that was no longer used, an when I turned it on to put it into circulation, I ejected the disk and put it aside.

    I hope this helps, but I'll post more info on year/model of the MacBook and more info on the install disks.

    Edit: Forgot to mention that the MacBook is running 10.6.8.
     
  4. minifridge1138 macrumors 6502a

    Joined:
    Jun 26, 2010
    #4
    The Grey disks from the iMac will not work.
    They are recovery disks specific to the Mac they came with (in this case they'll only work on an iMac).

    The white disk is universal and will work on any Mac capable of running Snow Leopard (which I think is all intel based macs).

    I think I heard 2 different problems (correct me if I'm wrong).

    1) After you logged in, you couldn't launch system preferences.
    2) One time when you tried to boot, you got the "!" and a caution triangle.

    The "!" at boot means that the Mac can't find a bootable volume.
    You could have a fried hard drive.

    You may just have to do a fresh installation of Snow Leopard.

    Hold the "option" key as you turn the computer. You'll see a list of every bootable volume the EFI (bios equivalent) finds. What do you see?
     
  5. Ylj thread starter macrumors newbie

    Joined:
    Jan 31, 2012
    #5
    Well, the first day I looked at the computer, the System Preferences app had a circle-slash over it.

    On the second day, I turned on the computer and after the Apple logo was on the screen for a while, a circle-slash appeared on the screen and remained their. I actually did try to do a install of Snow Leopard (the white disk I found), but when I checked on it after my classes, it said that the installation had failed.

    If it is a case of having a fried hard drive, would I be able to replace it with an iBook G4 hard drive?
     
  6. MagicBoy macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #6
    No.

    The iBook uses IDE drives, all MacBooks are SATA.
     

Share This Page