Need help with mail notifications

darrinS

macrumors 6502a
Original poster
Oct 21, 2011
541
176
So Cal
I am not sure what I did or what happened but I no longer get a haptic buzz when I get a mail notification. For Messages and other alerts I do feel the buzz. If I silence the speaker I won’t even know when I receive mail. But, if I hear my iPad play the sound of an incoming email and I raise my watch, I do see the notification of the email pop up on my watch, but again no buzz. If I have the speaker on, I do hear the beep sound but no haptic sensation.

I have looked in the settings on the watch and my iphone and just don’t see where the problem is at.

Thanks for any help.
 

StumpyBloke

macrumors 68020
Apr 21, 2012
2,220
1,871
England
Go in to the phone watch app, then notifications. Then mail. Then choose Custom.

Finally, tap each mail account and turn on Haptic feedback.

I had to do it on mine.
 
  • Like
Reactions: darrinS

darrinS

macrumors 6502a
Original poster
Oct 21, 2011
541
176
So Cal
Go in to the phone watch app, then notifications. Then mail. Then choose Custom.

Finally, tap each mail account and turn on Haptic feedback.

I had to do it on mine.
Thank you! Sure enough by following your steps the haptic was turned off. Thanks again.
 
  • Like
Reactions: StumpyBloke

darrinS

macrumors 6502a
Original poster
Oct 21, 2011
541
176
So Cal
@StumpyBloke and anyone else with this issue, when I switched from mimic iPhone to custom in the watch app, sure enough the haptic was turned off in the email settings. But then I didn’t seem to get any email notifications on my watch. No ping and no haptic. If I turned my iPhone off completely then I did get the ping and haptic on the watch.

I figured this out. In the watch app, switch back to mimic iPhone. Then open the settings app and go to Notifications -> Mail and open your different email accounts and choose sound. If you scroll all the way up to the top you will see that the vibration is set to Default, which means no vibration. Change that to one of the vibration options and you will feel a haptic vibration on the watch when you receive an email.
 

StumpyBloke

macrumors 68020
Apr 21, 2012
2,220
1,871
England
@StumpyBloke and anyone else with this issue, when I switched from mimic iPhone to custom in the watch app, sure enough the haptic was turned off in the email settings. But then I didn’t seem to get any email notifications on my watch. No ping and no haptic. If I turned my iPhone off completely then I did get the ping and haptic on the watch.

I figured this out. In the watch app, switch back to mimic iPhone. Then open the settings app and go to Notifications -> Mail and open your different email accounts and choose sound. If you scroll all the way up to the top you will see that the vibration is set to Default, which means no vibration. Change that to one of the vibration options and you will feel a haptic vibration on the watch when you receive an email.
Yes I know thanks

I posted this a while ago above to help others too. Worked for me but not for some sadly.
 

FatherOfTwo

macrumors regular
Jun 9, 2015
132
43
I ended up changing the Mail app I use on my phone. A bug that needs to be fixed by Apple
 

mtulman1

macrumors regular
Oct 17, 2015
147
55
I’m not getting any notifications at all. I have tried everything. This is my first 2 hours with an Apple Watch so I may be missing something. If I go to my Notification Center they don’t show. But When accessing the app it shows my unread messages etc. anyone have any ideas please.
 

darrinS

macrumors 6502a
Original poster
Oct 21, 2011
541
176
So Cal
I’m not getting any notifications at all. I have tried everything. This is my first 2 hours with an Apple Watch so I may be missing something. If I go to my Notification Center they don’t show. But When accessing the app it shows my unread messages etc. anyone have any ideas please.
Open the Apple Watch app on your iPhone and open Notifications -> Mail and choose Mirror my iPhone. Then open the iPhone Settings app and go to Notifications -> Mail and make sure you have the notifications turned on. Then enter each email account and turn on notifications. I have all of mine on for each account I have Banner, Lock Screen & Notification Center. Then open Sounds and scroll to top and choose a vibration other than Default. That should do it. Hope this helps.
 

mtulman1

macrumors regular
Oct 17, 2015
147
55
Open the Apple Watch app on your iPhone and open Notifications -> Mail and choose Mirror my iPhone. Then open the iPhone Settings app and go to Notifications -> Mail and make sure you have the notifications turned on. Then enter each email account and turn on notifications. I have all of mine on for each account I have Banner, Lock Screen & Notification Center. Then open Sounds and scroll to top and choose a vibration other than Default. That should do it. Hope this helps.
I reset my watch and repaired and it’s all good now. But thank you.
 

MrRugged

macrumors member
Nov 9, 2016
96
18
So I’ve had success with this but then it stopped and I switched to custom setting in the watch app and that now works. Unfortunately, I don’t get a red dot if I miss a mail notification. I get the haptic vibration but if I don’t look at it right away, there’s no red dot for me to pull down on the Notification Center to see what it is. Anyone have this problem?
 

vhl71

macrumors 6502
Oct 8, 2009
389
131
I've this issue - no matter what i try, i will not get a vibration or notification on my watch unless i wake up the screen
[doublepost=1538154029][/doublepost]this issue was happening with my SS glod watch 4. I just swapped my alum space black watch 4 to see.
The haptic feedback works on that watch!!

Strange - nothing has changed between these 2 watches. one works and other doesnt!!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.