Need help with my iMessage!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by BlindSoul, Sep 9, 2012.

  1. BlindSoul macrumors 6502

    Joined:
    May 30, 2010
    Location:
    Israel
    #1
    Hello,

    I have an iPhone 4 and lately when I send people text messages from the iMessage ( the blue Send button ) it shows them they receive the messages from my email and not from my phone number. Then they keep asking me who am I...

    How can I fix it?


    Thank you!
     
  2. aziatiklover macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
    #2
    Settings>messages>received at>choose your number instead of the email.
     
  3. BlindSoul thread starter macrumors 6502

    Joined:
    May 30, 2010
    Location:
    Israel
    #3
    I have my phone number in Grey and my email in Blue and it lets me change my email. that's all I have here.
     
  4. aziatiklover macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
    #4
    Is your iphone factory unlocked or gevey sim? Can you see your number when you go into settings? If you cant that means your iphone is not recognising the sim card number.
     
  5. BlindSoul thread starter macrumors 6502

    Joined:
    May 30, 2010
    Location:
    Israel
    #5
    Yeah it started since when I factory unlocked my iPhone.
    Inside Messages > Receive At it does show my real number. but it is in Grey colour and I can't choose it.
     
  6. aziatiklover macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
    #6
    Does it show your real number when you go to phone>contacts and scroll all the way on top? If it doesnt show your real number. Just remove the sim turn off then insert your sim back on again.
     
  7. BlindSoul thread starter macrumors 6502

    Joined:
    May 30, 2010
    Location:
    Israel
    #7
    Inside Phone it shows my real number yes.
    I don't have here Phone > Contacts
     

Share This Page