Need help with my IPOD TOUCH BADLY!!!!

Discussion in 'iPod touch' started by TongYunLo, Feb 9, 2008.

  1. TongYunLo macrumors newbie

    Joined:
    Feb 9, 2008
    #1
    Hey everyone, i've had my IPOD for a while now. I have upgraded and jailbroken to 1.1.2. Now the problem lies here.

    I had the installer and updated to 1.1.3 installer. But i hadn't installed the new 1.1.3 firmware yet, meaning the new itunes software. SO i then installed that after installing the 1.1.3 installer. When i tried upgrading, my ipod touch then suddenly seemed like it reebooted. Meaning it went to the screen where it asks you to plug in the usb cord and i can't do anything with it.

    Later it asked me to restore it and i tried to. It didn't work then i downloaded 1.1.1 and 1.1.2 software and tried restoring with either of those two and it still didn't work.

    Please can someone help me i really want to use the touch again.
     
  2. carisnator macrumors newbie

    Joined:
    Jan 25, 2008
    #2
    have u tried force restoring it with the home and sleep buttons?
     

Share This Page