Need Help with Networking issue!!

Discussion in 'Mac Basics and Help' started by gallootjs, Mar 15, 2008.

  1. gallootjs macrumors newbie

    Joined:
    Feb 20, 2008
    #1
    Hello,

    I am trying to share files between my Mac (OS X 10.5.2), desktop (XP Home) and laptop (XP Pro). The Mac and laptop can share files with one another, but the desktop is a problem. The desktop can see and share with the Mac, but the Mac cannot access the desktop's shared folder. When I "Connect to Server" from the Mac, I am asked to log in either as a "Guest" or Register User. Well, when I try to connect with my Mac's user name or desktop's user name I "Connection Failed - This file server does not allow (Guest) access." The thing is, I easily connect to the laptop using the same procedure. Other threads have suggested enabling NetBios, which had no effect.

    Any help would be appreciated. Thanks!

    -Johnny
     
  2. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #2
    Did you set a password on the XP system? I remember it was necessary that the account on the XP machine had a password set. You will then try connecting to it using the XP-account with the associated password.
     
  3. gallootjs thread starter macrumors newbie

    Joined:
    Feb 20, 2008
    #3
    Password

    Yes, I added a password to the desktop's user name but without success. I tried logging in with the user name of the desktop as well as the Mac. The strange thing is, when I connected to my laptop from my Mac I logged in as a registered user with the user name of the Mac (passwords are the same).
     
  4. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #4
    I always had problem with XP home sharing, while with XP pro things are much better. I now use XP pro on every machine, so a solution would be to upgrade to XP pro.

    Before going with the radical solution above I would try creating a new user account on your XP Home machine with the same username and password of the Mac.

    You may also try assigning a password to the Guest account in the XP machine and then connecting from the mac with it.

    To apply a Password to the guest account:

    1. Please log on to this computer with an Administrator account and turn
    on the guest account.
    2. Click Start->Run->Type cmd and click OK.
    3. Input the following command and press Enter. Net user guest puthereyournewpassword
    (4. Optionally: Go to Control Panel->User Accounts. Click the Guest account and now you can change the password.)


    Also try sharing a different folder in your XP home machine, as some folders may give problems. Try a coupe different folders.

    Does the sharing between the XPs machines works?
     
  5. gallootjs thread starter macrumors newbie

    Joined:
    Feb 20, 2008
    #5
    Ok, here's what I did (btw - The desktop and laptop share folders without a problem):

    1) I set up a user name and password on the XP home identical to OS X. No success.

    2) I tried to put a password on the Guest account via the command prompt, but when I checked to see if it applied (Control Pane > User Accounts) it did not say "Password protected."

    3) I tried 2 or three other folders to share. No success.

    4) As I said above, the XPs share just fine (and the desktop can access OS X too!!).

    Anyway, if you have any other suggestions I'd greatly appreciate it.

    -johnny
     
  6. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #6
    Let's see what else we can do... ;)

    Is the workgroup the same on each machine? If not change them to the same one, also on the Mac (in leopard should be somewhere under the network control panel).

    Can you describe me exactly what you get in the dialog after you try connecting with "connect to server"?

    Do you see your PCs in the Network (in Finder)?

    Try again setting the guest password following Microsoft instructions here:

    http://support.microsoft.com/?scid=kb;en-us;555520&x=15&y=7

    And then accessing with the guest at the windowsw-login to see if it works (you may have to disable the automatic login if you are using it, in windows).

    If it works (it ask for the password) try again from the mac.

    Installing XP pro isn't hard if you have a bit of experience in Windows. Just leave it as a last resort.


    A couple more things you may want to try separately (taken from here: http://www.macwindows.com/leopard.html#102907e ):

    Turn off filesharing on your mac and try connecting to the XP machines.

    Go to System Preferences | Sharing and select "File Sharing". If you have file sharing turned on click on the "Options..." button and make sure the option "Share files and folders using SMB" is checked. Click Done.

    Firewall settings (Security > Firewall > Advanced) and turned "Enable Stealth Mode" off.

    Let me know if anything works...
     
  7. gallootjs thread starter macrumors newbie

    Joined:
    Feb 20, 2008
    #7
    Unfortunately no luck. Here's what I did :

    1) The workgroup is "HOME" on the XP machines, and "home" on OS X. Does the lower case make a difference? Also, there are no "WINS Servers" listed. (I don't know if that makes a difference, but I thought the info might be useful).

    2) When I "Connect to Server" for the XP desktop I get the following dialog - "Enter you user name and password to access the file server <ip address>. Connect as : Guest or Registered User." If I try to connect as a guest I get "Connection Failed. The file server does not allow Guest access." If I try to connect as a registered user I get "Connection Failed. You do not have permission to access this server."

    3) I see the PCs in the Finder, but when I click the desktop I get "connection failed"

    4) I added a password to the Guest account in Windows, but when I am unable to share a folder (i.e., I cannot check the "Share this folder on the network" box). Also, if I try to connect as a guest I get the same response as above (same for my register user name).

    5) Turning off file sharing does not allow a connection.

    6) Under "Firewall", right now "Allow all incoming connections" is selected while the Advanced button is grayed out so I can't turn off "Enable Stealth Mode."

    Could this be an issue with my user name on the Mac? Do I need to make the users have the same name?

    I should mention that I am using a wireless usb adapter for the desktop's network connection.

    Thanks again for your help! Let me know if you have any other ideas.
     
  8. rhett7660 macrumors G4

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #8
    Try this..

    On your xp home make sure you are setup with the following:

    1. User name is associated as administrator
    2. You have a password for that user name
    3. The folders you want to see are shared, this is big for xp home. It will only see shared folders if I remember correctly.
    3a. Make sure the work groups are the same, don't know if it is case sensative, I wouldn't doubt if it is. So if you have all caps use all caps or what have you.

    4. Make sure on the Mac side you are logged in as an adminstrator account
    5. When you connect to server, connect as a registered user
    6. Enter the user name and password of the xp machine, not the Mac machine

    See if that helps.
     
  9. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #9
    A good source of guides you maybe already know is the following:

    http://www.ifelix.co.uk/tech/

    Maybe once they make the one for 10.5 you will find something helpful. Although the fact that you can connect to XP pro without problems suggests XP home may be the problem.

    When you try the previous suggested operations remember to restart the XP machine after every change.
     
  10. rhett7660 macrumors G4

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #10
    Correct.. Make sure to restart your xp machine, forgot to put that in.....
     
  11. gallootjs thread starter macrumors newbie

    Joined:
    Feb 20, 2008
    #11
    Great. I will work on your suggestions tonight and will post the results Wednesday (I am away tomorrow). Thanks again for all the help!!
     

Share This Page