Need Help with OS 4.0 beta woes...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by nickinbeta, Jun 1, 2010.

  1. nickinbeta macrumors newbie

    Joined:
    Jun 1, 2010
    #1
    Alright, I may sound like an idiot for ever putting the os on my iphone in the first place but here it goes...

    I got the 4.0 beta installed on my 3gs by a dev that I knew, thought I'd try it out and such. Everything was working fine until I soon noticed that I could not backup to iTunes. Puzzled I was, but I pushed it aside hoping for an iTunes update. More time passed, I then hoped that when the real os 4 was released it would overwrite my beta firmware (also turned out to be ill conceived). Now tonight I am staring at a "please connect to itunes" screen and no phone using ability (I wasn't aware I would be locked out after a time period).

    I don't need posts saying "Well that's what you get for using beta software n00b" or "Just go buy a developer account". If I could get some real advice here, like pointing me in the right direction giving me options, it would be much appreciated.
     
  2. mrat93 macrumors 65816

    mrat93

    Joined:
    Dec 30, 2006
  3. nickinbeta thread starter macrumors newbie

    Joined:
    Jun 1, 2010
    #3
    Thanks :D, one more question remains. Is it possible at this point to somehow do a backup? I have read other threads that say you need the OS 4 SDK or some such to be able to properly perform backups through itunes (I am no dev so cannot access the SDK). Is there any other way?
     
  4. ozzyman500 macrumors 65816

    Joined:
    Feb 4, 2009
    #4
    :D:):eek:
     
  5. ipadforever macrumors newbie

    Joined:
    Jun 2, 2010
    #5
    Jailbreak Firmware 4.0 : Redsn0w 0.9.5 Beta 4 is out ! you can find it here
     
  6. nickinbeta thread starter macrumors newbie

    Joined:
    Jun 1, 2010
    #6
    Hmmm... seems that jailbreaking using redsnow is only possible using their newest beta which can only run under Mac (I only have windows) :(.
     
  7. nickinbeta thread starter macrumors newbie

    Joined:
    Jun 1, 2010
    #7
    Alright, said screw trying to back up... However, now I can't seem to even downgrade it. Always in the end brings me back to the your software has expired state.
     

Share This Page