Need help with signing/certificate. Getting Error *Please Help*

Discussion in 'iOS Programming' started by iJustinCabral, Jul 17, 2012.

  1. iJustinCabral macrumors member


    Jul 8, 2012
    I had recently updated my mac mini to a 256gb SSD.

    I'm using mountain lion & Xcode 4.4 DP3 with Xcode iOS SDK 6.0

    Also my phone is running iOS 6.0 DP3

    I have my Developer certificate, but when I try to build an app onto my device, I get this error:

     The identity 'iPhone Developer' doesn't match any valid, non-expired certificate/private key pair in your keychains 
    Can anyone help me?
  2. firewood macrumors 604

    Jul 29, 2003
    Silicon Valley
    Check the Developer certificate in your Keychain and make sure its Private key is valid (was copied from your old HD correctly). If not, either recover it from backups, or go to the developer portal and follow the instructions to regenerate a completely new certificate, as the one currently there is useless without the proper key.

    Make sure the Apple WDR intermediate certificate is also in your keychain.
  3. iJustinCabral thread starter macrumors member


    Jul 8, 2012
  4. samdev macrumors regular

    Sep 16, 2011
    Did you backup your private key before you replaced your hard drive?
    You should have done this if you didn't.

Share This Page