need help with spinning rainbow

Discussion in 'iMac' started by MacM4ODA, Jan 10, 2009.

  1. MacM4ODA macrumors regular

    Joined:
    Jan 10, 2009
    Location:
    Arizona
    #1
    HI Folks, new here, i have had this iMac OS X ver: 10.5.4 for a year, i use FoxFire as a browser, i have many Bookmarks, now my iMac has slowed to a crawl and i get the spinning rainbow for several minutes before it gives me the URL i select from the Bookmark menu.

    what do i need to do to get my iMac to respond the way it did when new ?? and get rid of the spinning rainbow ?

    do i have too many Bookmarks or do i need more memory ?

    thank you all in advance for your help and concern.
     
  2. bizzle macrumors 6502a

    Joined:
    Jun 29, 2008
    #2
    Check your drive's health. You can do that by using SMART Utility, which has a free trial located here: http://www.volitans-software.com/products.php

    Second, assuming your hard drive is in good health, run your updates. I suggest you run the combo update to 10.5.6, not the incremental in Software Update, which is available here: http://support.apple.com/downloads/Mac_OS_X_10-5-6_Combo_Update

    After that's installed, run Software Update for any other updates.

    I would export your bookmarks, for backup, and run AppCleaner (http://www.freemacsoft.net/AppCleaner/) and remove Firefox. This will clear all preferences for the application as well, which most likely are causing your issues. After that, reinstall and reimport your bookmarks.
     
  3. MacM4ODA thread starter macrumors regular

    Joined:
    Jan 10, 2009
    Location:
    Arizona
    #3
    thank you for your help, i'll have to call Apple today, nothing i try seems to work and appears to have gotten worse.

    once more, thank you :)
     
  4. MacM4ODA thread starter macrumors regular

    Joined:
    Jan 10, 2009
    Location:
    Arizona
    #4
    i called Apple yesterday and it turned out to be some sort of corruption in Firefox, "option, command + esc" was the answer along with "spotlight" to clear the "permissions" log.

    i am now back to speed, in fact the tech told me to do this at least once a month but once a week would be better.
     

Share This Page