Need help with unlock!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kimbers, Sep 18, 2007.

  1. kimbers macrumors newbie

    Joined:
    Sep 18, 2007
    #1
    Hello!

    My coworker asked me to unlock his iphone. I have activated and "jailbreak"ed it with iNdependence on Mac OS X. I was following the instructions on modmyiphone website, and got stuck at the CyberDuck part.
    http://modmyiphone.com/wiki/index.php/IPhone_unlock_OS_X_Part_4

    When I try to connect to the phone via CyberDuck, I get a timeout error message. (I'm using the wifi at work.) I changed the timeout settings in CyberDuck to 60 seconds. Still no luck.

    Does anyone have a workaround? I'd hate to start over on a Windows computer---I'm so close....

    How do I get anySIM on the iphone?

    Thanks in advance for your help!
     
  2. b257177 macrumors regular

    Joined:
    Jul 25, 2007
    #2
    I also use iNdependence to unlock my iPhone. You mention being at work... are you able to use port 22, which is the port your SSH'ing into? Can you SSH into your iPhone? It might be a firewall thing.

    Also, make sure the iPhone has an IP address and is transmitting/receiving data over said Wi-Fi. Bring up a web page is the fastest way.

    Lastly, make sure you have re-started the iPhone in question, at least once since installing the SSH.
     
  3. kimbers thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #3
    I'm not sure if I am "able" to use port 22 at work, but I have it in the settings for CyberDuck. I'm not sure if a firewall is preventing me from using CyberDuck.

    I am sure that the phone is connected on wi-fi. I did browse to a new (no chance of being cached) webpage and then recorded the IP address afterwards.

    Both the computer and the iphone have been restarted.

    Is there any other option for me? How about Bluetooth?
     
  4. kimbers thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #4
    ok, i am scratching all that i have done. Restored phone, and activated and jailbreaked with iNdependence. Are there instructions I can follow for mac without using wi-fi?
     
  5. Mydel macrumors 6502a

    Mydel

    Joined:
    Apr 8, 2006
    Location:
    Sometimes here mostly there
    #5
    You have to use Wi-Fi. I used Fugu and worked well.
     
  6. kimbers thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #6
    During the unlock procedures, is the original iphone at&t sim suppose to be in the phone?

    At what point do I remove the iphone sim?

    Will unlock work for all sims, including Cingular prepaid or business account sims?
     
  7. kimbers thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #7
    Yippee! The phone is now unlocked.

    I used both Mac and Windows.

    Mac---used iNdependence software to Activate and Jailbreak phone

    Then on Windows: used these instructions skipping first 2 sections, went straight to unlock:
    http://www.theiphoneunlock.com/free-unlock-manual-english/

    Was able to make phone calls with both Tmobile and Cingular sims!

    This is awesome!
     
  8. Orchidthief macrumors newbie

    Joined:
    Sep 18, 2007
    #8
    Kimbers, what plan do you have on Tmobile? I'm currently have a sidekick and have the total internet plan. Just wondering if your process allowed all the features(minus visual voicemail) to function.

    Also, did you do it on a phone that was straight out of the box and never activated?

    Just wondering cus I'm suppose to receive my iPhone today....
     
  9. kimbers thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #9
    I just have a regular calling plan with TMobile, no data; and I didn't have my SIM in the phone for very long before I handed it back over to my coworker. But I have heard that TMobile's total internet does work with the iPhone. I just ordered my own iphone yesterday, and when I get it, I am going to sign up for TMobile's total internet.

    We did have the phone connected via our office's wireless internet to the internet and were able to access webpages and YouTube.

    So how is that Total Internet plan? Is the internet connection as readily available as the phone connection?

    The ModMyIphone website has some info on connecting the iPhone to TMobile internet. Check out the bottom of this page:
    http://modmyiphone.com/wiki/index.php/IPhone_unlock_OS_X_Part_4
     
  10. Orchidthief macrumors newbie

    Joined:
    Sep 18, 2007
    #10
    Kimbers,

    well i got it unlocked and it's now working with Tmobile. I have a sidekick3 with the unlimited data plan, however, that plan supposedly doesn't work. I switched out that plan to the total internet plan which supposedly works.

    I changed the APN to what that guide stated and still to no avail. I get a message saying that I'm not an Edge subscriber. I can however connect to the internet using wifi. The only catch is that the youtube feature doesn't work. Whn I click on youtube it says it cannot connect.

    Anyone have any tips?
     
  11. b257177 macrumors regular

    Joined:
    Jul 25, 2007
    #11
    I had the exact same issue. It's a timing thing on the provisioning side at T-Mobile, getting the Unlimited Internet going. I called T-Mobile tech support and they were able to "push" the process along and get me provisioned. Otherwise, it should work itself out (and allow you to login to EDEG) within about 24-48 hours.

    When I called T-Mobile, I asked for level 2 Internet Data plan technical support. I then got a good rep who knew what she was doing. And, they loved the fact I had an iPhone working on their network.
     
  12. Orchidthief macrumors newbie

    Joined:
    Sep 18, 2007
    #12

    Well....thanks for the input. It actually kicked in about an hour within changing my plan from the sidekick unlimited data plan to the total internet plan. Now everything seems to function as if I were an AT&T user(minus the visual voicemail).....other than that, this thing is awesome.....
     

Share This Page