Need help with USB 2.0 microSD dongle

Discussion in 'Mac Basics and Help' started by mac000, Dec 15, 2007.

  1. mac000 macrumors 6502a

    Joined:
    Sep 6, 2005
    #1
    I have a usb 2.0 dongle that connects to a microSD card and it was pulled out while it was mounted, now the darn thing wont mount and i can't reformat it. I originally formatted it fat32 under windows, now it doesn't mount under osx but is recognized in disk utility, and mounts under windows but i cannot access the files on it or reformat it or do anything with it.

    I Just want to erase the thing and reformat. under windows when i right click format I get an error saying windows just can't complete the operation and under osx's disk utility (erase, partion, (tried everything))

    Disk Erase failed with the error:

    Input/output error


    I tried restarting, plugging into different USB drives, shut down. Is the microSD card fried or what?

    This is probably something very typical that happens but i've tried everything i know and i solve the problem and I could use some help. Someone please lend a hand here, thanks.
     
  2. jnc macrumors 68020

    jnc

    Joined:
    Jan 7, 2007
    Location:
    Nunya, Business TX
    #2
    What device do you use the microSD in? Is there anyway on-board to delete/reformat it?
     

Share This Page