Need help with windows 8 installation on iMac late 2012

Discussion in 'Windows, Linux & Others on the Mac' started by dodgymin, Mar 28, 2013.

  1. dodgymin macrumors newbie

    Joined:
    Mar 28, 2013
    #1
    I have been trying to install windows 8 on my imac for several days and have failed. Please help.

    I have iMac late 2012 with intel i7, 3TB fusion drive.
    Bootcamp has not been working with 3TB model until quite recently. when it did, I tried to install windows.

    when I got the computer after christmas last year, the first thing i did was to break the fusion drive into 2 separate physical drives. i installed the osx mountain lion on the SSD and used the 3TB as storage and time machine. Now I have 128GB SSD, which has only 30GB left, and 3TB HDD.

    Here is what I have been trying to achieve.

    SSD must stay as it is.
    I would like to make 3 partitions on 3TB HDD. 1.8TB, 1TB and 200GB each.
    I would like to install windows 8 on 200GB partition and use other 2 partitions as storage and time machine.

    once i formatted 200GB partition as NTFS using disk utility on osx.
    when i try to install windows, it says it cannot be installed because of GPT style disk. I have googled and found out about EFI boot. but when i do a error message "we couldnt create a new partition or locate a existing one" appears.

    then i tried to leave 200GB as free space using disk utility and format the partition during the windows installation process. if i create new partition within the free space, 200GB partition breaks down into 5,6 partitions of 128MB and 200MB. it says they are system drives and MBR reserved.

    If i choose primary partition of 190GB, it proceeds to the next step. during the installation process with check list, it stops working in the first step, "copying installation files" and error message, which i cant recall at the moment, appears and it tells me to restart the computer to continue. when i do, it does not work.

    when i go back to osx and open disk utility to format the 3TB HDD, it has 7 or 8 partitions of 128MB, 200MB.

    I wondered if there was anything wrong with the windows installation file. so i tried to install it with whole 3TB HDD as a single partition. it works fine. I have now formatted the HDD but EFI boot still appears if i bring up boot option. when i select it, it says critical files are missing. well, i have formatted the disk. they are supposed to be missing. but why do i get the boot option?

    Is there any way that i can install windows 8 as i want it?
    1.8TB, 1TB and 200GB partitions and windows 8 installed on 200GB.

    Please help.

    P.S
    I have tried fdisk and gdisk. I couldnt understand the process fully.
    I did something with one of them. i cant remember what it was but it was something to do with converting GPT to MBR.

    please please help.
     
  2. dodgymin thread starter macrumors newbie

    Joined:
    Mar 28, 2013
    #2
    one more thing

    i forgot to mention that i also tried this.
    format the 3TB HDD completely using cmd

    >diskpart
    >select disk
    >clean
    >create partition
    etc..

    and create 200GB partition and left 2.8TB as free space.
    it works.
    and when i tried to partition the free space in osx using disk utility, it does not work.
    the progress bar filles up and stays so for hours.
    i left it like that over night, and it still is after 8,9 hours.
    when i quit disk utility, it asks me there is incomplete process.

    is this possible at all?
    create partition using windows cmd and partition the rest free space using disk utility?
     

Share This Page