Need iMovie between 6 and 11

Discussion in 'Mac Apps and Mac App Store' started by raebot, Jul 19, 2012.

  1. raebot macrumors newbie

    Joined:
    Jul 19, 2012
    #1
    Today I was using iMovie and running into some walls, so I tried Googling what to do and found many very helpful answers that had no bearing whatsoever on my version of iMovie. I then realized I had been faithfully updating my iLife software but not once have I performed an upgrade...so I've got the iMovie that's been on my MacBook Pro since I got it in early 2007.

    The app store, however, says the newest iMovie won't run unless I have Lion. I don't want Lion and I'm not even fully certain I can run it on my computer. I tried finding old iLife software in the App Store (nada) and in Apple's downloads on their site (updates exist, but not upgrades - can't install).

    How in the world can I get a version of iMovie between the one I have (too old) and the one that's in the App Store (too new)?

    Thanks.
     
  2. JediMeister, Jul 21, 2012
    Last edited by a moderator: Jul 22, 2012

    JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    You should buy a copy of iLife '08 or iLife '09 from Amazon or another software reseller and install. Apple no longer sells that software.
     

Share This Page