Need Old version of Itunes for OSX 10.4

Discussion in 'Mac Basics and Help' started by DeccaSounds, Dec 21, 2009.

  1. DeccaSounds macrumors newbie

    Joined:
    Dec 21, 2009
    #1
    Been searching for a bit, and even a few posts on this forum but nothing has helped so Im just going to ask. I have an old G4 running osx 10.4. Tried to upgrade so my ipod would be compatible and ended up locking out my old version. I need something above 4.9, are any ones available for 10.4 above this??
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
  3. DeccaSounds thread starter macrumors newbie

    Joined:
    Dec 21, 2009
    #3
    I have 10.4.1, but the new itunes requires the new quicktime, which needs leopard, that I dont have, and dont want to run it on my old machine hmm
     
  4. jackerin macrumors 6502a

    Joined:
    Jun 29, 2008
    Location:
    Finland
    #4
    I am looking at the Quicktime download page in another tab and I see two options: QuickTime 7.6.4 for Leopard and QuickTime 7.6.4 for Tiger. Download the one for Tiger. (Protip: Tiger is 10.4.)
     
  5. pdjudd macrumors 601

    Joined:
    Jun 19, 2007
    Location:
    Plymouth, MN
    #5
    And as always, make sure that you have all the latest software updates.
     
  6. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #6
    Update to 10.4.11 and the latest software by going to the apple menu and select "software update."

    Latest version of iTunes and quicktime work with it. You'll get the latest iTunes with that automatic update.
     
  7. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #7
    And the latest version of QuickTime.
     

Share This Page