Need plug-in for MIME type application/x-shockwave-flash

Discussion in 'Mac Apps and Mac App Store' started by Menehan, Jun 12, 2008.

  1. Menehan macrumors newbie

    Joined:
    Jun 12, 2008
    #1
    1. I try to open a video on Youtube.

    2. I’m told I need Adobe Flashplayer:
    Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player. (click here)


    3. I click there and download it … but when I hit “install” I’m told:

    Safari can’t find the plug-in.
    This page has content of MIME type “application/x-shockwave-flash”, but you don’t have a plug-in installed for this MIME type. A plug-in should be available on this page:

    https://www.macromedia.com/go/getflashplayer

    Do you want to open the page?


    4. Then when I say “yes, I want to go to that page,” I’m taken back to the page on which I can download Adobe Flashplayer.

    This is a circuitous cycle that never results in my actually getting the plug in. Can anyone help?
    Thanks!
    Karen
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Yes, download the Adobe Flash plug-in from this Adobe webpage.
     
  3. Menehan thread starter macrumors newbie

    Joined:
    Jun 12, 2008
    #3
    Still need plug-in

    Thank you, but that's actually the same page I've been directed to lo these many times... I seek just the plug-in, not flash player.
     
  4. Menehan thread starter macrumors newbie

    Joined:
    Jun 12, 2008
    #4
    I fixed it!

    If anyone else has this problem, do this:


    Find disc utility, then hit "repair permissions."
     
  5. SeanGO macrumors newbie

    Joined:
    Jun 25, 2008
    #5
    Hi Menehan, I have this same problem, could you help me to solve it? You say find disc utilities-but I cant find it- could you talk me through nice & simple for a techno-dummy
    Thanks S.
     
  6. lpeifang macrumors newbie

    Joined:
    Jun 28, 2008
    #6
    disc utility

    Hi,
    I know where to find disc utility. go to: application>utilities>disc utility>click 'Repair Disk Permissions'. that's all:)
     
  7. rmaxt macrumors newbie

    Joined:
    Jul 10, 2008
    #7
    its DISK not DISC

    do the SPOTLIGHT (apple-spacebar) and type disk utility
    it will pop right up as the first choice on the list

    cheers!
     
  8. 12ern macrumors newbie

    Joined:
    Jul 14, 2008
    #8
    still got problems!!??

    i understand how to get on to disk utility but it will not let me click repair permissions..... the button is faded?:confused:
     
  9. 10smom macrumors regular

    10smom

    Joined:
    Mar 26, 2008
    Location:
    USA
    #9
    You have to highlight the hard drive you want to repair in this case it is your mac hard drive
     
  10. Freda People macrumors newbie

    Joined:
    Jul 19, 2008
    #10
    The permissions repair didn't work for me...???

    Maybe I need to re-boot...I will try...
     
  11. Freda People macrumors newbie

    Joined:
    Jul 19, 2008
    #11
    WORKED! re: Flash Player 8 Installer/Internet Plug-In Issue

    Force a Universal application to open using Rosetta:

    1. Click the application's icon in the Finder. (You can click and hold on Safari in the Dock and select "Show Item in Finder" to go directly to it)
    2. From the Finder File menu, choose Get Info (or press Command-I).
    3. Select the checkbox named "Open using Rosetta."
    4. Close the Get Info window.

    Now, when you double-click the application, it will open with Rosetta, and any non-Universal plug-ins should work.
     
  12. fletchnj macrumors newbie

    Joined:
    Dec 31, 2007
    #12
    wow

    what a pain in the rear! thank goodness for this site, repairing permissions did the trick.
     
  13. jrjung macrumors newbie

    Joined:
    Dec 29, 2008
    #13
    still can't get shockwave-flash download for internet explorer 5.2

    As suggested, I repaired permissions on Mac OS 10.4... but when I got to the getadobe.com/flashplayer site, I get error msg that it will not work with my platform
     
  14. 10smom macrumors regular

    10smom

    Joined:
    Mar 26, 2008
    Location:
    USA
    #14

    interent explorerer does not work on mac unless using the widows side of dual processor. If that the case then need to download windows version of adobe flash to the windows OP system on your mac!
     
  15. Swingbean macrumors newbie

    Joined:
    Oct 16, 2009
    #15
    try a different browser

    Hi,

    I couldn't get the mime thing to work either, even with "repairing permissions" (thank you who noted to do that), until I went off of Safari and opened up Firefox. Immediately, there was no more problem and everything worked.

    Good luck.
    Swingbean
     
  16. Appleonly macrumors newbie

    Joined:
    Oct 31, 2009
    #16
    Nothing Worked - still getting same message

    Help. I have done everything suggested here - have an intel iMac OS 10.4 - had no problems with this plug-in thing until today. What could have changed? Tried Firefox, Rosetta - I first noticed on my Farmville game on Facebook today.

    Any help would be really appreciated::eek:
     
  17. Appleonly macrumors newbie

    Joined:
    Oct 31, 2009
    #17
    Finally

    Thanks to this forum . . . finally got back to Farmvil:Dle . . .
     
  18. truyang macrumors newbie

    Joined:
    Nov 8, 2009
    #18
    i'm having the same problem too. i tried deleting the plug in and downloading a new one but it doesn't help.

    can someone please help me step by step on what to do? i would really appreciate it.
     
  19. grannygardener macrumors newbie

    Joined:
    Dec 18, 2009
    Location:
    in beautiful Utah
    #20
    FINALLY a solution that worked.

    Thank you so much Freda People.
    That annoying pop up telling me 'the plug-in couldn't be found' has finally left the building.
     
  20. perfectpitcher2 macrumors newbie

    Joined:
    Nov 30, 2010
    #21
    mime application/download

    I had this same situation before. Every time I open YouTube and other flash sites, I always get this message :

    The page “YouTube - Meet Single File” has content of MIME type “application/x-shockwave-flash”. Because you don’t have a plug-in installed for this MIME type, this content can’t be displayed.

    I've already tried Disk Repair to repair the permissions, installed, re-installed Flash Player and Shockwave Player and nothing yet. System preferences with QuickTime Advanced Panel to enable flash and the other miscelaneous one I unchecked, the normal procedure, I guess. Also checked the libraries to see if I didn't have the plugin in two libraries, but i'm not sure about the library/plugin issue. Seems like I have to perform some mime application/download or something.

    Then a friend suggested me to downloaded the flash uninstaller, uninstall it and try to reinstall again. So I searched Macromedia's/Flash website for the uninstaller for Mac OS X, and it worked. :)
     

Share This Page