Need some help with menubar clock format

Discussion in 'macOS' started by jon08, Nov 27, 2009.

  1. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #1
    Ok so I'm already using the 24-hr format, which is what I wanted, but one thing that bothers me is that it is in "00-23" format, but I would like it in "0-23".

    I set it to "0-23" in Language & Text\Formats\Times, but there seems to be no effect. I tried logging out and in again, but to no avail. Was I supposed to reboot for it to take effect, or am I simply doing something wrong and hence no change?
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    Check your International>Formats preference pane. (I'm using OS10.5.8) Click Customize in the Time panel.

    My Hour is a single digit. What's yours? It might be over-riding the other setting.
     
  3. jon08 thread starter macrumors 65816

    Joined:
    Nov 14, 2008
    #3
    Are we talking about the "Short" format here? I have "19 : 08" under "Short"... And I selected "0-23" by clicking on the above-mentioned "19".
     
  4. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #4
    I don't see Short as a heading in the International pane that I referred you to. I also don't see it in Date & Time. So, no, that's not what I was talking about.

    Your sig doesn't mention your OS, but I gather from the pref pane title you referred to that it's Snow Leopard. I'm still using Leopard.
     
  5. jon08 thread starter macrumors 65816

    Joined:
    Nov 14, 2008
    #5
    Well in Snow Leopard "International" has been renamed to "Language & Text", so once you click on it and then "Format", everything is more or less the same.........
     
  6. crewrules101 macrumors member

    Joined:
    Aug 9, 2007
    #6
    Go to system prefs. then select Picture 2009-12-13 at 11.05.25 AM.png . after that select Picture 2009-12-13 at 11.05.34 AM.png . that window should appear as Picture 2009-12-13 at 11.04.58 AM.png . Finally select the "Customize" under the "times" area which should open as Picture 2009-12-13 at 11.05.07 AM.png . Finally you should see the "Short" area and you can change the format there by dragging or selecting the area you want to change and you should be set.
     
  7. dipnlik macrumors newbie

    Joined:
    Jan 10, 2010
    #7
    So, this procedure doesn't work here. I recently installed Snow Leopard and have the same issue. Tried to customize the times a lot but the values set there doesn't seem to affect SL's menubar clock :(

    Weird thing is: in System Preferences, Date & Time, Clock, if I disable the 24-hour clock the hour loses the preceding zero.

    Any other ideas?
     
  8. jon08 thread starter macrumors 65816

    Joined:
    Nov 14, 2008
    #8
    The way I fixed it was change the Region in the Formats section... and it worked...
     

Share This Page