Need someone to help with an Icon BG

Discussion in 'Jailbreaks and iOS Hacks' started by redbeard331, Dec 20, 2010.

  1. redbeard331, Dec 20, 2010
    Last edited: Dec 20, 2010

    redbeard331 macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #1
    I don't have photoshop, and if I did I still don't think I'd know how to do this, but I need the icon I attached to have a clear background so just the round speaker is visible, exactly how it looks in the attachment. It looks right until I put it on my phone, and then the speaker has a normal icon sized black square around it.

    Thanks in advance..

    I attached another pic of how it looks on my phone..
     

    Attached Files:

  2. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
  3. geque75 macrumors regular

    Joined:
    Jun 16, 2010
    #3
    I took the image, made it my phone icon and it looked fine on my phone (no black background)
     

    Attached Files:

  4. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #4
    Oh wow, haha my phone is weird I guess..:eek:
     
  5. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #5
    Hmmm, I keep trying and no matter what, that black background persists..:eek:
     
  6. geque75 macrumors regular

    Joined:
    Jun 16, 2010
    #6
    what are you trying to do? Where do you see the background? Can you send me some files you are using and I can see if I can replicate it?
     
  7. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #7
    Well I've tried getting the image from the source again, thinking maybe I did something to it, I'm just dumping it onto my phone using winscp.

    I found it here >> http://commons.wikimedia.org/wiki/File:ITunes_alt_Mac.png

    Thanks for the help
     
  8. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #8
    Well this is getting ridiculous, I tried seeing if making the background transparent using Gimp since I don't have photoshop, yet it didn't work, the background is still there, it just turned it white. :confused:

    There has to be a way to fix this, any help would be appreciated!
     
  9. geque75, Dec 23, 2010
    Last edited: Dec 23, 2010

    geque75 macrumors regular

    Joined:
    Jun 16, 2010
    #9
    Do you have iPhone 4? What icon are you trying to replace with this? Again, I have taken the image you loaded above, make it my phone icon and this is what it looks like on my phone.
     

    Attached Files:

  10. Chromus macrumors regular

    Joined:
    May 20, 2010
    #10
    It is possible the icon doesn't fit well with the theme you have since they are both very different. Have you tried disabling your theme?
     
  11. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #11
    Yea I've got an iphone 4.

    I'm trying to make this the icon for Midomi Soundhound.

    I see it shows up correctly on your phone too, it's weird, because it used to show up properly on mine until about a month ago, and I'm having this issue with other icons as well..
     
  12. THE dAY macrumors 6502

    Joined:
    Jul 22, 2010
    Location:
    SFV California
    #12
    Redbeard, for what it's worth, I tried the image on my phone as well and I get the same black background behind the speaker.

    I tried the icon on both appstore and default icons and get the same result.

    I'm on iPhone 4, 4.0.1.
     
  13. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #13
    Weird, I really want to figure this problem out cause I love tweaking my phone and I get ocd about it, I know how to theme just about everything on the phone now, and it's really frustrating to not be able to find away to correct this.
     
  14. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #14
    Still not resolved, I seem to have had this problem ever since I upgraded to 4.1, has to be something to do with it I'd think.
     
  15. Los macrumors regular

    Joined:
    Jul 5, 2010
    #15
    SSH into your iPhone or use iPhone Explorer. Go to /System/Library/PrivateFrameworks/MobileIcons.framework/

    In there, change the filename of "AppIconMask@2x.png" to "AppIconMask@2x_alt.png" or something so you know it's the original. DO NOT DELETE IT!

    Then simply respring. The black border should go away. However, this will cause all other "unthemed" icons to look squared.
     

Share This Page