Need to change files in time machine backup

Discussion in 'Mac Basics and Help' started by coolio49085, Jul 31, 2009.

  1. coolio49085 macrumors newbie

    Joined:
    Jul 31, 2009
    #1
    Hi,
    I've searched the internet trying to get help with this for several hours now, so I figured I'd bring it to you guys.


    So, this whole problem started when I wanted to dual boot on my macbook pro. It's a 2008, 4gb ram, 2.5 ghz dc, with leopard. I started to do a backup, but time machine kept on preparing and wouldn't start backing up. So, I canceled it and just copy and pasted my entire computer onto my external. I formatted, reinstalled mac os, partitioned for windows, worked out all of the kinks with windows, and then I finally got to reinstating my mac's status.

    When I went to go to reinstall all of my personal files, I started with applications and that went pretty well. I then tried to replace my user folder, but I was told I didn't have proper authority or something to replace the folder on my computer. So, I thought, "Maybe if I put the folder with my backup files in it inside the backups.Backupdb folder, when I go in time machine it'll recognize it as a backup and I should have no problem." Stupid, Jarod. I renamed the file xx-xx-xxxx-xxxxxxxx; similar to the other backups. I then placed the folder into the backup.backupdb folder. It popped up with something pertaining to authorization, so I clicked authorize and it was successfully placed in the folder. Except, it didn't work.


    Now, when I try to take it out of the backup.backupdb folder, it doesn't allow me to because of authorization. I can't change, copy or delete any files even though I have given myself the permission to via "get info".

    I don't mind just reinstalling everything, although that would be a pain, I just really need the files that were in that last "unofficial" backup.

    Has anybody else ever done this? And, if so, how would I go about fixing it?
    I just want to get that one folder out of there.

    Thanks a ton,
    Jarod
     
  2. oculus42 macrumors 6502

    Joined:
    Dec 9, 2002
    Location:
    Maine
    #2
    Maybe Hosed, Maybe Not

    This is total speculation. If you were to change disks in Time Machine (in System Preferences), you may get the ability to access those files normally.

    Alternately, if you have access to another Mac (Especially 10.4, so no Time Machine support), try accessing the drive from there to see if you can move around the Time Machine files.

    If you are still in your support contract window, I'd call Apple to see what they can do or tell you.
     
  3. coolio49085 thread starter macrumors newbie

    Joined:
    Jul 31, 2009
    #3
    Yeah, I tried that already as well as just now, and, unfortunately, I'm out of apple's reach by a few months.

    I did several terminal processes to try and re-author the disk or something. I also, deleted the preference for it in utilities/systempreferences or something along those lines. It would seem like I should be able to de-sensitize the files or something like that.

    I apologize if I come off like a idiot on a mac. I'm a convertee.
     
  4. oculus42 macrumors 6502

    Joined:
    Dec 9, 2002
    Location:
    Maine
    #4
    Actually, it makes sense that Mac OS X Leopard would see those files as Time Machine files, even if they aren't for your computer... that way you can't accidentally destroy someone else's backup files.

    I just opened the sparebundle for my Time Machine backup. I was able to copy files out of a backup folder. The permissions were wacky on them, but I did copy the files out.
     
  5. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #5
    Sorry to say, but simple copy and paste of files will cause problems. You should have cloned your drive with SuperDuper.
     

Share This Page