Need to fix "another device is using your IP address on this network"

Discussion in 'Mac Basics and Help' started by Keukasmallie, Dec 1, 2016.

  1. Keukasmallie macrumors regular

    Keukasmallie

    Joined:
    Jan 30, 2011
    Location:
    WNY
    #1
    When I open the cover of my MBP I receive this message:

    Screen Shot 2016-11-23 at 11.35.01 AM.png

    BUT I am able to use the network w/o any problems. So, how can I get rid of the annoying message?

    (I have one-by-one disconnected printer, iPhone charger, smart TV, etc...no joy.)
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    If your router has the option to configure DHCP Reservations you should take a few minutes and do it for all of your network devices. That way, each device will always have the same local IP address and the router won't give the reserved IP addresses to any new devices added to the network.
     
  3. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
    You could try to restart the router -- unplug the power cable for the router, leave it for a minute, and plug the power cable back in.

    If that doesn't work, login to your router and change the wireless encryption to WPA2-PSK only (no mixed mode). It may also be called WPA2-AES.
     
  4. addamas macrumors 6502

    addamas

    Joined:
    Apr 20, 2016
    #4
    Exactly, only PSK AES no TKIP anymore (high risk of hack).

    Some devices in network might have set static ip which your device is also asking for.
     
  5. Keukasmallie thread starter macrumors regular

    Keukasmallie

    Joined:
    Jan 30, 2011
    Location:
    WNY
    #5
    My router is an AirPort Extreme, 7.6.7 version (When I click on the network icon in the toolbar I find that my network shows WPA2 Personal as the security level.). How do I find the wireless encryption screen to make a change?
     
  6. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    That model has DHCP reservations. Configure those, make sure none of you devices are set to a "manual" IP, and you won't be bothered with the message from your original post again.
     
  7. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #7
    Or if you do have something set to manual, set it to a number in the same subnet, but out of the range used by the DHCP server, say 192.168.0.204
     
  8. Peter Franks macrumors 65816

    Joined:
    Jun 9, 2011
    Location:
    London UK
    #8
    I've had this on and off for 8 + years..... never bothered taking any notice of it, just presume it's when I use the iPhone while the MBP is on, and it's a lot rarer I see it these days, but do still on occasion get it. Didn't think I had to bother with it
     
  9. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #9
    The reservation procedure will certainly work, but why not explore your devices to learn which has a fixed IP address, and then change that one to get its IP via DHCP? With every device uses regular DHCP you won't need to make reservations.

    From your description, it's probably your Macbook that's got the fixed IP address.

    But as JohnDS says, if you have one set to manual and it cannot be changed, then get it outside a range and you'll be good.
     
  10. mibtp macrumors newbie

    Joined:
    May 18, 2015
    #10
    I got this message when I was on an open wifi network at a car dealership while waiting for my care to be repaired. I assumed this meant some scammer was trying to use my computer to do lotharios activities. Was I wrong? I immediately disconnected from their network.
     
  11. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #11
    No. It just means that there was a conflict between IP addresses. No Lotharios involved, except maybe the car salesmen.
     
  12. phrehdd macrumors 68040

    phrehdd

    Joined:
    Oct 25, 2008
    #12
    Pretty simple fix. Disconnect your connection for a moment. Then reconnect again. Your AE should hand you another IP. You don't have to turn off your AE or whatever else. If the screen keeps coming up, sadly you may want to restart your computer but usually resetting your IP is sufficient.

    Sometime we let our system sleep or hibernate etc. This doesn't cleanly disconnect the computer the computer expects to go back into action with the last IP used before sleeping or hibernate. If the router considers it timed out, it may re-assign that IP elsewhere as needed. It's pretty straight forward. (IF I am understanding your original post correctly).
     
  13. Keukasmallie thread starter macrumors regular

    Keukasmallie

    Joined:
    Jan 30, 2011
    Location:
    WNY
    #13
    I tried most of the above recommendations, but no joy. I ignored the whole deal for some time then realized I was no longer receiving the error message. Maybe the cumulative effect of trying several things, then letting them steep for a bit finally resolved the issue. Or Apple figured I had paid the price and went ahead and fixed it for me....
     
  14. mibtp macrumors newbie

    Joined:
    May 18, 2015
    #14
    Good one!

     

Share This Page