Need to Regain Write Permissions on External Devices

Discussion in 'Mac Basics and Help' started by Geekier, Feb 16, 2011.

  1. Geekier macrumors newbie

    Joined:
    Feb 16, 2011
    #1
    I just tried following this tutorial here and failed hard.

    Regrettably I got stuck mid way through and now I'm noticing a couple of problems with my external HDD I currently have mounted as well as when I try and mount my flash drive.

    I used to have Read/Write abilities on my external HDD and now I only have Read. On top of this, when I try to eject any device my mac hangs and I can't even force eject them.

    Here's a screen shot of what happens when I try to eject a device:
    [​IMG]

    I'm running Snow Leopard 10.6.6 and if anyone knows how I can regain having default write permissions and ejecting devices I'd really appreciate it.
     
  2. kirky29 macrumors 65816

    kirky29

    Joined:
    Jun 17, 2009
    Location:
    Lincolnshire, England
    #2
    You could try in Disk Utility repairing permissions for the drive?

    I had a similar issue like this, and it worked for me :)
     

Share This Page