Need to Relaunch Finder (Spinning Wheel) Every Few Clicks (MacOS Sierra)

Discussion in 'macOS Sierra (10.12)' started by trevor2522, Jul 3, 2017.

  1. trevor2522, Jul 3, 2017
    Last edited: Jul 3, 2017

    trevor2522 macrumors member

    Joined:
    Sep 1, 2011
    #1
    Macbook Pro 13-inch, 2011, 525 GB SSD, MacOS Sierra 10.12.5 .

    I *may* have inadvertently caught a virus from a bad website. The Finder, which I am not using, apparently crashes every few random mouse clicks, requiring Alt-Cmd-Esc to clear it with Force Quit Applications (Finder only). The Mac is otherwise useable except for this irritating defect which slows down work considerably. I have tried :

    PRAM reset
    SMC reset
    Disk Utility repair feature

    Clearing the dyld Cache (tried but would not understand the Terminal command or accept the correct password)

    At the Terminal prompt, enter the following command. Please note this is a single line; some browsers may show this command spanning multiple lines.
    sudo update_dyld_shared_cache -force
    Press enter or return.
    You will be asked for an administrator account password.
    Once the password is accepted, Terminal may display some warning messages about mismatches in the dlyd cache. Don't worry; these are warnings about the content that is being cleared out and then updated by the command.

    Another recent fault is that the Trash will not clear. Only 61 items but when clearing it counts up to hundreds of thousand of files, and then never clears any!

    Never experienced these issues prior to Sierra, or even initially with Sierra. Any ideas? Can I scan for viruses? Should I re-install MacOS Sierra 10.12.5 or High Sierra? High Sierra is a public beta but could it pick up any virus present from existing Sierra? Other users seem to experience Spinning Ball and Trash issues with Sierra too. Thanks very much.
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Two things to try.
    1. Download and run Malwarebytes. Do a scan of your system from the menu. It only takes a few seconds to complete.
    That will tell you if any relevant malware has found its way to your system. (Malwarebytes is a good tool to run occasionally - maybe once a month or less often.)
    2. Download and run EtreCheck. Post the resulting log here. Someone can interpret that listing, if you don't see anything obvious to you.
    Those two tests will help you decide if there is some basic issue with the software on your system.
     
  3. trevor2522, Jul 3, 2017
    Last edited by a moderator: Jul 4, 2017

    trevor2522 thread starter macrumors member

    Joined:
    Sep 1, 2011
    #3
    Thanks very much. I managed to clear the Trash by closing all apps first (seems a quirk of Sierra) -- silly mistake!

    Malwarebytes: 8 threat files (2 Screen Shots) -- Cleared.

    Code:
    EtreCheck version: 3.4 (420)     LONG ... comments welcome !
    
    Report generated 2017-07-03 16:46:55
    
    Download EtreCheck from https://etrecheck.com
    
    Runtime: 5:26
    
    Performance: Below Average   (Any worry ? )
    
    
    
    Click the [Lookup] links for more information from Apple Support Communities.
    
    Click the [Details] links for more information about that line.
    
    Click the [Remove/Report] links to remove adware or update the whitelist of legitimate software.
    
    Click the [Clean up] link to delete unused files.
    
    
    
    Problem: No problem - just checking (Reason:  spinning ball cleared itself just prior to download !)
    
    
    
    Hardware Information: ⓘ
    
        MacBook Pro (13-inch, Early 2011)
    
        [Technical Specifications] - [User Guide] - [Warranty & Service]
    
        MacBook Pro - model: MacBookPro8,1
    
        1 2.3 GHz Intel Core i5 (i5-2415M) CPU: 2-core
    
        4 GB RAM Upgradeable - [Instructions]
    
            BANK 0/DIMM0
    
                2 GB DDR3 1333 MHz ok
    
            BANK 1/DIMM0
    
                2 GB DDR3 1333 MHz ok
    
        Bluetooth: Old - Handoff/Airdrop2 not supported
    
        Wireless:  en1: 802.11 a/b/g/n
    
        Battery: Health = Normal - Cycle count = 111
    
    
    Video Information: ⓘ
    
        Intel HD Graphics 3000 - VRAM: 384 MB
    
            Color LCD 1280 x 800
    
    
    Disk Information: ⓘ
    
        Crucial_CT525MX300SSD1 disk0: (525.11 GB) (Solid State - TRIM: Yes)
    
        [Show SMART report]
    
            EFI (disk0s1 - MS-DOS FAT32) <not mounted>  [EFI]: 210 MB
    
            Crucial SSD 525GB 9-10-2016 (disk0s2 - Journaled HFS+) /  [Startup]: 524.25 GB (422.34 GB free)
    
            Recovery HD (disk0s3 - Journaled HFS+) <not mounted>  [Recovery]: 650 MB
    
    
        MATSHITADVD-R   UJ-898  ()
    
    
    USB Information: ⓘ
    
        USB20Bus
    
            hub_device
    
                Generic 4-Port USB 2.0 Hub
    
                    Western Digital My Passport 0829
    
                        My Passport 0829 disk2: (2 TB)
    
                            EFI (disk2s1 - MS-DOS FAT32) <not mounted>  [EFI]: 210 MB
    
                            My Passport for Mac (disk2s2 - Journaled HFS+) /Volumes/My Passport for Mac : 2.00 TB (1.27 TB free)
    
                    Logitech USB Receiver
    
                    Canon MG7700 series
    
                Apple Computer, Inc. IR Receiver
    
        USB20Bus
    
            Apple Inc. FaceTime HD Camera (Built-in)
    
            hub_device
    
                Apple Inc. Apple Internal Keyboard / Trackpad
    
                Apple Inc. BRCM2070 Hub
    
                    Apple Inc. Bluetooth USB Host Controller
    
    
    Firewire Information: ⓘ
    
        WD My Passport 071D 800mbit - 800mbit max
    
            (disk1s1) <not mounted>  [partition_map]: 32 KB
    
            (disk1s2) <not mounted>  [Driver43]: 29 KB
    
            (disk1s3) <not mounted>  [Driver43]: 29 KB
    
            (disk1s4) <not mounted>  [Driver_ATA]: 29 KB
    
            (disk1s5) <not mounted>  [Driver_ATA]: 29 KB
    
            (disk1s6) <not mounted>  [FWDriver]: 262 KB
    
            (disk1s7) <not mounted>  [Driver_IOKit]: 262 KB
    
            (disk1s8) <not mounted>  [Patches]: 262 KB
    
            My Passport Studio (disk1s10 - Journaled HFS+) /Volumes/My Passport Studio : 1.00 TB (363.58 GB free)
    
    
    Thunderbolt Information: ⓘ
    
        Apple Inc. thunderbolt_bus
    
    
    Virtual disks: ⓘ
    
        Malwarebytes Anti-Malware (disk3s1 - HFS+) /Volumes/Malwarebytes Anti-Malware : 32 MB (14 MB free)
    
            Physical disk: Disk Image 32 MB (14 MB free)
    
    
    
    System Software: ⓘ
    
        macOS Sierra  10.12.5 (16F73) - Time since boot: less than an hour
    
    
    Gatekeeper: ⓘ
    
        Mac App Store and identified developers
    
    
    Possible adware: ⓘ
    
        Unknown file: ~/Library/LaunchAgents/com.appactivity.AppActivity.plist
    
            ~/Library/Application Support/AppPolicy/AppActivity -i -c 748931 -isn DEFB744F-1A9D-4285-998E-372DDAA2EB37
    
        Adware: ~/Library/LaunchAgents/com.jdibackup.ZipCloud.autostart.plist
    
        Adware: ~/Library/LaunchAgents/com.jdibackup.ZipCloud.notify.plist
    
        3 possible adware files found. [Remove/Report]
    
    
    Clean up: ⓘ
    
        ~/Library/LaunchAgents/com.citrixonline.GoToMeeting.G2MUpdate.plist
    
            ~/Library/Application Support/CitrixOnline/GoToMeeting/G2MUpdate
    
            Executable not found!
    
        ~/Library/LaunchAgents/com.jdibackup.ZipCloud.autostart.plist
    
            open /Applications/ZipCloud.app/Contents/Resources/Utility.app -n --args 9 -l
    
            Executable not found!
    
        ~/Library/LaunchAgents/com.jdibackup.ZipCloud.notify.plist
    
            open /Applications/ZipCloud.app/Contents/Resources/Utility.app --args 7 1
    
            Executable not found!
    
        ~/Library/LaunchAgents/jp.co.canon.Inkjet_Extended_Survey_Agent.plist
    
            /Applications/Canon Utilities/Inkjet Extended Survey Program/Inkjet Extended Survey Program.app/Contents/Resources/Canon_Inkjet_Extended_Survey_Agent
    
            Executable not found!
    
        4 orphan files found. [Clean up]
    
    
    Kernel Extensions: ⓘ
    
            /Library/Application Support/org.pqrs/Karabiner
    
        [loaded]    org.pqrs.driver.Karabiner (10.21.0 - SDK 10.11) [Lookup]
    
    
    
            /Library/Application Support/org.pqrs/Karabiner-Elements/Karabiner-VirtualHIDDevice
    
        [loaded]    org.pqrs.driver.Karabiner.VirtualHIDDevice.v040400 (4.4.0 - SDK 10.12) [Lookup]
    
    
    
            /Library/Extensions
    
        [loaded]    com.sophos.kext.oas (9.6.51 - SDK 10.11) [Lookup]
    
        [loaded]    com.sophos.nke.swi (9.6.51 - SDK 10.11) [Lookup]
    
    
    
            /System/Library/Extensions
    
        [not loaded]    com.lct.driver.LJACDDriver (1.0.0d1) [Lookup]
    
        [not loaded]    com.lja.driver.LJACDDriver (1.0.1) [Lookup]
    
        [not loaded]    com.tomtom.driver.UsbEthernetGadget (1.0.0d1) [Lookup]
    
        [not loaded]    lja.driver.USBModemCDC (1.0.0) [Lookup]
    
        [not loaded]    lja.driver.USBModemCDC64 (4.0.2) [Lookup]
    
        [not loaded]    lja.driver.USBModemData (1.0.0) [Lookup]
    
        [not loaded]    lja.driver.USBModemData64 (4.0.2) [Lookup]
    
    
    
    System Launch Agents: ⓘ
    
        [not loaded]    8 Apple tasks
    
        [loaded]    183 Apple tasks
    
        [running]    91 Apple tasks
    
    
    System Launch Daemons: ⓘ
    
        [not loaded]    40 Apple tasks
    
        [loaded]    176 Apple tasks
    
        [running]    101 Apple tasks
    
    
    Launch Agents: ⓘ
    
        [failed]    com.adobe.ARMDCHelper.cc24aef4a1b90ed56a725c38014c95072f92651fb65e1bf9c8e43c37a23d420d.plist (Adobe Systems, Inc. - installed 2017-01-10) [Lookup]
    
        [loaded]    com.google.keystone.agent.plist (Google, Inc. - installed 2017-03-29) [Lookup]
    
        [loaded]    com.oracle.java.Java-Updater.plist (? 889c9bfa be93c7fb - installed 2017-06-14) [Lookup]
    
        [running]    com.sophos.uiserver.plist (Sophos - installed 2017-04-11) [Lookup]
    
        [running]    org.pqrs.karabiner.karabiner_console_user_server.plist (Fumihiko Takayama - installed 2017-03-19) [Lookup]
    
    
    Launch Daemons: ⓘ
    
        [loaded]    com.adobe.ARMDC.Communicator.plist (Adobe Systems, Inc. - installed 2017-01-10) [Lookup]
    
        [loaded]    com.adobe.ARMDC.SMJobBlessHelper.plist (Adobe Systems, Inc. - installed 2017-01-10) [Lookup]
    
        [loaded]    com.adobe.fpsaud.plist (? 2afb3af7 a0305b84 - installed 2017-06-15) [Lookup]
    
        [loaded]    com.bombich.ccchelper.plist (Bombich Software, Inc. - installed 2016-10-09) [Lookup]
    
        [loaded]    com.google.keystone.daemon.plist (Google, Inc. - installed 2017-04-18) [Lookup]
    
        [running]    com.malwarebytes.HelperTool.plist (Malwarebytes Corporation - installed 2017-07-03) [Lookup]
    
        [loaded]    com.oracle.java.Helper-Tool.plist (Shell Script e3fefdd2 - installed 2017-03-15) [Lookup]
    
        [running]    com.sophos.common.servicemanager.plist (Sophos - installed 2017-02-07) [Lookup]
    
        [loaded]    jp.co.canon.MasterInstaller.plist (Canon Inc. - installed 2016-10-04) [Lookup]
    
        [not loaded]    org.pqrs.Karabiner.load.plist (Shell Script 44439558 - installed 2016-07-05) [Lookup]
    
        [running]    org.pqrs.karabiner.karabiner_grabber.plist (Fumihiko Takayama - installed 2017-03-19) [Lookup]
    
        [loaded]    uk.co.canimaansoftware.ClamXavHelper.plist (Mark Allan - installed 2016-09-30) [Lookup]
    
        [loaded]    uk.co.canimaansoftware.ClamXavHelperUpdater.plist (Mark Allan - installed 2016-09-30) [Lookup]
    
    
    User Launch Agents: ⓘ
    
        [running]    com.appactivity.AppActivity.plist (? eb155aef 2363b378 - installed 2016-08-31) [Lookup]
    
        [loaded]    com.citrixonline.GoToMeeting.G2MUpdate.plist (? b9b97797 0 - installed 2014-10-18) [Lookup] - ~/Library/Application Support/CitrixOnline/GoToMeeting/G2MUpdate: Executable not found!
    
        [failed]    com.jdibackup.ZipCloud.autostart.plist (? 8bb15285 0 - installed 2016-09-17) Adware!  [Remove/Report]
    
        [loaded]    com.jdibackup.ZipCloud.notify.plist (? d1f994bf 0 - installed 2016-09-17) Adware!  [Remove/Report]
    
        [not loaded]    jp.co.canon.Inkjet_Extended_Survey_Agent.plist (? 5e3c5637 0 - installed 2016-10-04) [Lookup] - /Applications/Canon Utilities/Inkjet Extended Survey Program/Inkjet Extended Survey Program.app/Contents/Resources/Canon_Inkjet_Extended_Survey_Agent: Executable not found!
    
        [loaded]    uk.co.canimaansoftware.clamxav.UninstallWatcher.plist (Mark Allan - installed 2016-09-30) [Lookup]
    
    
    Internet Plug-ins: ⓘ
    
        FlashPlayer-10.6: 26.0.0.131 (installed 2017-06-16) [Lookup]
    
        QuickTime Plugin: 7.7.3 (installed 2017-06-15)
    
        AdobePDFViewerNPAPI: 17.009.20044 (installed 2017-04-14) [Lookup]
    
        AdobePDFViewer: 17.009.20044 (installed 2017-04-14) [Lookup]
    
        Flash Player: 26.0.0.131 (installed 2017-06-16) [Lookup]
    
        EPPEX Plugin: 10.0 (installed 2016-05-23) [Lookup]
    
        Google Earth Web Plug-in: 7.1 (installed 2016-10-08) [Lookup]
    
        Silverlight: 5.1.50428.0 (installed 2016-08-17) [Lookup]
    
        JavaAppletPlugin: Java 8 Update 131 build 11 (installed 2017-06-14) Check version
    
    
    
    User internet Plug-ins: ⓘ
    
        CitrixOnlineWebDeploymentPlugin: 1.0.105 (installed 2013-04-26) [Lookup]
    
        WebEx64: 1.0 (installed 2014-09-19) [Lookup]
    
    
    
    Safari Extensions: ⓘ
    
        [enabled]    Adblock Plus - Eyeo GmbH - https://adblockplus.org/ (installed 2016-12-25)
    
        [enabled]    AdBlock - BetaFish, Inc. - https://getadblock.com (installed 2017-04-26)
    
    
    3rd Party Preference Panes: ⓘ
    
        Flash Player (installed 2017-06-15) [Lookup]
    
        Java (installed 2017-06-14) [Lookup]
    
    
    Time Machine: ⓘ
    
        Auto backup: YES
    
        Volumes being backed up:
    
            Crucial SSD 525GB 9-10-2016: Disk size: 524.25 GB Disk used: 101.91 GB
    
        Destinations:
    
            My Passport for Mac [Local]
    
            Total size: 2.00 TB
    
            Total number of backups: 36
    
            Oldest backup: 31/05/2017, 15:59
    
            Last backup: 03/07/2017, 16:01
    
            Size of backup disk: Excellent
    
                Backup size 2.00 TB > (Disk size 524.25 GB X 3)
    
    
    Top Processes by CPU: ⓘ
    
          114%       Google Chrome Helper
    
            47%       Google Chrome Helper
    
            46%       java
    
            30%       WindowServer
    
            12%       mds
    
    
    Top Processes by Memory: ⓘ
    
        535 MB        java
    
        432 MB        kernel_task
    
        326 MB        Google Chrome Helper
    
        211 MB        Google Chrome Helper
    
        122 MB        com.malwarebytes.HelperTool
    
    
    Top Processes by Network Use: ⓘ
    
        Input         Output        Process name
    
        2 MB          315 KB        SophosWebIntelligence
    
        424 KB        2 KB          java
    
        23 KB         66 KB         SophosSXLD
    
        14 KB         59 KB         SophosMcsAgentD
    
        9 KB          6 KB          apsd
    
    
    Top Processes by Energy Use: ⓘ
    
        111.50    Google Chrome Helper
    
        35.08    WindowServer
    
        31.90    Google Chrome Helper
    
        29.46    java
    
          5.92    Safari
    
    
    Virtual Memory Information: ⓘ
    
        699 MB        Available RAM
    
        29 MB         Free RAM
    
        3.32 GB       Used RAM
    
        670 MB        Cached files
    
        730 MB        Swap Used
    
    
    Software installs: ⓘ
    
        Adobe Flash Player:  (installed 2017-06-13)
    
        Canon IJScanner15f:  (installed 2017-06-13)
    
        Canon IJ Printer Driver:  (installed 2017-06-13)
    
        Java 8 Update 131:  (installed 2017-06-14)
    
        Adobe Flash Player:  (installed 2017-06-16)
    
    
    
        Install information may not be complete.
    
    
    Diagnostics Information: ⓘ
    
        2017-07-03 16:34:17    Last shutdown cause: 3 - Hard shutdown
    
        2017-07-03 16:25:30    Finder.app Hang [Open]
    
        2017-07-03 16:22:28    Google Chrome.app Crash [Open]
    
        2017-07-01 15:15:22    VLC.app Crash [Open]
    
            Cause:        *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[SUAppcastItem copyWithZone:]: unrecognized selector sent to instance 0x6000004cb6e0'
    
            abort() called
    
            terminating with uncaught exception of type NSException
    
        2017-07-01 14:17:27    Safari.app Crash [Open]
    
            Cause:        Performing @selector(_lockButtonClicked:) from sender RolloverImageButton 0x6080003fa200
    
        2017-06-30 19:54:48    com.apple.WebKit.WebContent High CPU use [Open] [Details]
     

    Attached Files:

  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    Yes, as I suspected.
    The EtreCheck shows several items with the "remove" listed at the end of the line, and I think those are all listed together under "Possible Adware". I would call that "Likely Adware", and you should be completely safe with choosing to remove those items. EtreCheck will do that for you when you click "Remove".
    Restart your Mac.
    Run EtreCheck again, also run Malwarebytes to see that it runs clean (no malware found)
    Just my opinion, one "performance eater" that you can also safely remove would be the Sophos antivirus that you have installed. Follow the steps that Sophos provides to make sure it is completely removed from your system.
    Notice how effective THAT (Sophos) was :D EtreCheck helped you a lot more than Sophos did, and you don't have to leave EtreCheck running (it does not run in the background)

    Another item --- Karabiner (for customizing your keyboard). It is not currently supported in Sierra, so you may as well remove that, too.

    Finally, I see that you have 4GB of RAM memory installed. Easy to upgrade, and the 2011 13-inch MBPro can be upgraded to as much as 16GB, should you want to do that. IMHO, 8GB would be a good match for that nice Crucial SSD that you have, too.
     
  5. trevor2522, Jul 3, 2017
    Last edited: Jul 3, 2017

    trevor2522 thread starter macrumors member

    Joined:
    Sep 1, 2011
    #5
    Thanks a lot. I've removed Sophos. Malwarebytes was clear. Etrecheck now excellent from below average! Karabiner does do the few keystrokes I need, so I'll keep it. The SSD upgrade gave me all the speed I needed, when working correctly. Do you think I'd notice much improvement, especially for financial charts, if I upgraded to a 15-inch Retina model? Could you recommend a good secondhand SSD model available 'Apple Refurbished' (via Amazon)? Can I buy AppleCare to cover such models retroactively? Mechanically I can't fault my 2011 MBP 13" (no AppleCare).
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    You would have more screen space on a 15-inch, if that is important to you.

    I would continue to use the 13-inch, unless you expect to need updates to continue to use your apps.
    You can continue to upgrade to current macOS versions, maybe another 2 years, so it may depend on the OTHER software that you use --- such as for your financial charts (Excel?)
    A Retina model won't have a built-in optical drive, if that is relevant for you.
    Other than that, the processor/graphics performance continue to improve, and the screen itself will have a sharper image (because of that "retina" tech) The SSD performance continues to improve, too.

    Again, I would continue to use your 2011, with a fairly new SSD, now that your system has a better "attitude"...
    The primary issue could be the battery, if original. If you never use it as a portable (taking on-site, or traveling), then that may not be important for you, either. If you most often just use it on your desk, then you might even add a larger external monitor, which would also take care of screen space issues, if that is something that interests you.
     
  7. trevor2522 thread starter macrumors member

    Joined:
    Sep 1, 2011
    #7
    My charts are web-based. I changed the original battery with the SSD. I looked at external monitors but the resolution does not compare with Retina, or even pre-Retina Macs, like mine. A 17-inch MacBook would be ideal but the originals from 6 years ago are too old now. I could travel with the 13" (for optical drive) plus a secondhand Retina 15". These would provide backup in case of individual failure.

    However, in trading, size is important because more history is shown -- important for viewing support and resistance levels, plus improved general overview. All professionals use large monitors, typically 28 or 32-inch, often in multi-screen (4-6) setups. I just need a setup to tide me over whilst 'in transit'. Are secondhand MBP Retina 15s with SSD reliable value-for-money given the substantial cost new? Thanks again.
     
  8. trevor2522 thread starter macrumors member

    Joined:
    Sep 1, 2011
    #8
    Sorry to trouble you all again but the Spinning Ball is back whenever I click on any desktop file or try to clear the trash. The Finder is 'not responding' in the Force Quit box and has to be quitted to avert the ball, which soon comes back whenever I try to perform any task. Ran Malwarebytes and EtreCheck again but no issues found. Etrecheck performance down from Excellent to Good. I'm getting fed up with this! Can you advise me how to do a completely-clean install of Sierra? Is it worth trying High Sierra? Thanks.
     
  9. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #9
    https://support.apple.com/en-us/HT204904. If that does not work than the other option is to manually create a bootable USB installer.
     
  10. trevor2522 thread starter macrumors member

    Joined:
    Sep 1, 2011
    #10
    Thanks Taz. Something is making the Finder ultra-sensitive to any mouse clicks. I still have my original Snow Leopard disks from 2011. Could I format the hard drive and install Snow Leopard? I know Sierra has had several issues ... the question is: would Snow Leopard or Sierra be the 'least worse'?
     
  11. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #11
    Give a clean install of Sierra a try again since you will be running it off an SSD. You may need to do a careful install of your system again. I would first suggest using it clean first for a sanity check.

    I use Sierra and find it very stable.
     
  12. MC6800 macrumors 6502

    Joined:
    Jun 29, 2016
    #12
    Also don't forget the Console -- it may have relevant error messages, or at least give a hint as to what's causing this.
     
  13. trevor2522 thread starter macrumors member

    Joined:
    Sep 1, 2011
    #13
    Nothing obvious. Setting the double-click speed on the mouse to medium from highest helps somewhat, as does double-clicking more slowly. Rapid keystrokes cause the Finder to crash, even though I'm not using the Finder. Just tried swapping the optical mouse for a wired mouse but no change -- still ultra-sensitive to crashing.
     
  14. MC6800 macrumors 6502

    Joined:
    Jun 29, 2016
    #14
    I'd look at the Finder crash reports next, looking for anything they all have in common. That's Console's Log List on the left side > Diagnostic and Usage Information > System Diagnostic Reports > Finder_*
     
  15. trevor2522 thread starter macrumors member

    Joined:
    Sep 1, 2011
    #15
    Nothing obvious in Activity Monitor (see screen shot). However, closing Chrome, with my online financial charts and trading platform, does make this 2011 MacBook Pro more stable. Fewer tasks for the CPU makes it less prone to crashing. Could it be due to having only 4 GB RAM then pushing the system too hard? Worth trying an upgrade to 8 GB (£50) or 16 GB (£95) perhaps? Thanks for the ongoing assistance.
     

    Attached Files:

  16. MC6800 macrumors 6502

    Joined:
    Jun 29, 2016
    #16
    It shouldn't be causing a Finder crash, but Activity Monitor's Memory Pressure level (Memory tab, bottom) should be showing if it's in trouble.

    If 4GB of RAM isn't enough to use a web browser, the world has gone insane.
     
  17. trevor2522 thread starter macrumors member

    Joined:
    Sep 1, 2011
  18. trevor2522 thread starter macrumors member

    Joined:
    Sep 1, 2011
    #18
    https://discussions.apple.com/thread/7703294?start=0&tstart=0

    1. Close Finder if it's open.

    2. Open an Applications > Utilities > Terminal window and paste the following commands:

    rm ~/Library/Preferences/com.apple.finder.plist

    rm ~/Library/Preferences/com.apple.preferences.extensions.FinderSync.plist

    3. Then reboot.

    This thread gives 2 lines of Terminal code. Enter one by one and reboot. Seems to have stabilised the Finder constantly crashing! Advisor stated:

    "The problem was corrupt preference files and those commands removed them. Finder then created new ones, so you may have to customise your preferences for Finder again."

    This is a novel solution which I shall certainly keep to hand in case of any repeat.
     

Share This Page