need to restore... without using restore!

Discussion in 'Jailbreaks and iOS Hacks' started by tessthetyrant, Jun 10, 2011.

  1. tessthetyrant macrumors newbie

    Joined:
    Jun 10, 2011
    #1
    So far as I know, this is a unique problem. I did a search on the site and couldn't find anything... but then again, I did put myself in this situation.

    I received my iPhone 4 about a week ago, and as I was syncing it, I noticed it would not update to iOS 4.3.3. (it came with 4.3 loaded on it). I decided to ignore it for a while, as I had to go.

    Quickframe to yesterday, when now I'm trying to update to 4.3.1 and 4.3.3 by manually downloading the IPSWs, saving them and using shift+click Update. The update goes all the way, fully extracting the software, but when it gets to "verifying update with Apple" then I get a 3194 error "iPhone could not be restored. An unknown error occurred (3194)." I even just manually downloaded 4.3, and the same thing happened.

    What I really wanted to do was jailbreak it, so I used redsn0w 0.9.6rc16 to jailbreak, selecting the 4.3.1 IPSW when prompted. It seemed to have worked fine, but the Cydia icon was just blank white. Weird. When I opened it, it would immediately crash and revert back to home screen. The weird thing is, this also happens with Safari, but with no other app.

    Now, I want to just return my iPhone, since it won't restore OR update to any other iOS, but I know they'll blame my problems on the jailbreak, and call the warranty void. So, I just want to take the jailbreak off.

    I'm using iTunes 10.3.1.55 on Windows Vista, all Vista updates installed.

    tl;dr -- I need to remove the redsn0w jailbreak off my iPhone 4 WITHOUT using the 'restore' or 'update' functions on iTunes.

    If you need any other info, or want a video of me trying to restore so you can see all the steps, let me know. Pretty desperate here.
     
  2. murdercitydevil macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #2
    Just do a DFU restore and Apple should automatically update it to the latest version.

    EDIT: you could also do "erase all settings" and see if iTunes recognizes it then
     
  3. Happytodd macrumors regular

    Joined:
    Oct 19, 2010
    #3
    The most common problem with not getting your iPhone to update is because your iTunes is not up to date. Check to make sure it is up to date! =]
     
  4. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #4
  5. tessthetyrant thread starter macrumors newbie

    Joined:
    Jun 10, 2011
    #5
    Hey everyone, I really appreciate all the help, but none of these have helped. I put it into DFU and tried to restore, but the same 3194 error came up. I'm thinking now about simply sending it back to Apple, because I can't find any solutions.
     
  6. Benji222 macrumors 65816

    Benji222

    Joined:
    Dec 21, 2009
    Location:
    So Cal
    #6
    fic your hosts file and you should be fine...
    your phone is also fine... no reason to bring it to apple.
     
  7. tessthetyrant thread starter macrumors newbie

    Joined:
    Jun 10, 2011
    #7
    Yes, this worked, thanks a lot Benji222. I had put in a line of code for a previous hack on my 3GS, and forgot to take it out -- this was causing the problem the whole time. For anyone else stuck with this problem, make sure your hosts file is reset to normal, and you're fixed!

    I appreciate all the help, everyone!
     

Share This Page